#9130 closed defect (fixed)

new "Invalid DTS" reporting issue ?

Reported by: hydra3333 Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: nvenc
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Hello.
I see some new issue has likely been introduced in recent commits ?
It now occurs on multiple input files.

Can you please advise ?

With git head 2021.02.27 "git-2021-02-27-f9cb557", I am now getting lots and lots of this type of message:

[mp4 @ 000002291724f040] Invalid DTS: 1122816 PTS: 1122304 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1123328 PTS: 1122816 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1124352 PTS: 1123840 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1124864 PTS: 1124352 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1125376 PTS: 1124864 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1126400 PTS: 1125888 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1126912 PTS: 1126400 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1127424 PTS: 1126912 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1128448 PTS: 1127936 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1128960 PTS: 1128448 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1129472 PTS: 1128960 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1130496 PTS: 1129984 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1131008 PTS: 1130496 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1131520 PTS: 1131008 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1133056 PTS: 1132544 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1133568 PTS: 1133056 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1134080 PTS: 1133568 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1135104 PTS: 1134592 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1135616 PTS: 1135104 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1136128 PTS: 1135616 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1137152 PTS: 1136640 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1137664 PTS: 1137152 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1138176 PTS: 1137664 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1139200 PTS: 1138688 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1139712 PTS: 1139200 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1140224 PTS: 1139712 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1141248 PTS: 1140736 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1141760 PTS: 1141248 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1142272 PTS: 1141760 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1143296 PTS: 1142784 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1143808 PTS: 1143296 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1144320 PTS: 1143808 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1145856 PTS: 1145344 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1146368 PTS: 1145856 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1146880 PTS: 1146368 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1147904 PTS: 1147392 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1148416 PTS: 1147904 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1148928 PTS: 1148416 in output stream 0:0, replacing by guess
[mp4 @ 000002291724f040] Invalid DTS: 1149952 PTS: 1149440 in output stream 0:0, replacing by guess

ffmpeg version git-2021-02-27-f9cb557-Hydra3333/python_cross_compile_script_v100/3333 Copyright (c) 2000-2021 the FFmpeg developers

built with gcc 10.1.0 (GCC)
configuration: --prefix=/home/u/Desktop/_working/workdir/win64_output/ffmpeg_git_3333.installed --disable-shared --enable-static --arch=x86_64 --target-os=mingw64 --cross-prefix=x86_64-w64-mingw32- --pkg-config=pkg-config --pkg-config-flags=--static --disable-shared --enable-static --disable-w32threads --enable-pthreads --enable-cross-compile --target-exec=wine --enable-runtime-cpudetect --enable-gpl --enable-version3 --extra-version=Hydra3333/python_cross_compile_script_v100/3333 --enable-pic --enable-bzlib --enable-zlib --enable-lzma --disable-fontconfig --disable-libfontconfig --disable-libfreetype --disable-libfribidi --disable-libbluray --disable-libcdio --enable-avisynth --enable-vapoursynth --disable-librtmp --disable-libcaca --enable-iconv --enable-libxml2 --enable-gmp --enable-gnutls --enable-libzimg --enable-libx264 --enable-libx265 --enable-libvpx --enable-libdav1d --disable-libaom --enable-libxvid --enable-gray --enable-libopus --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libsoxr --enable-librubberband --disable-libass --enable-libwebp --enable-ffnvcodec --enable-cuvid --enable-cuda-llvm --disable-opengl --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --disable-libmfx --disable-amf --disable-opencl --extra-libs='-lpsapi -lintl -liconv -lssp' --enable-nonfree --enable-libfdk-aac --disable-decklink --enable-libtwolame --enable-libzvbi --enable-libgsm --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-libsnappy --disable-frei0r --enable-libsrt --enable-libbs2b --enable-libilbc --disable-libgme --disable-libflite --enable-sdl2 --enable-libopenmpt --enable-libmysofa --enable-libvidstab --disable-libmodplug --disable-schannel --extra-cflags=-DLIBTWOLAME_STATIC --extra-cflags=-DMODPLUG_STATIC --extra-cflags=-DLIBXML_STATIC --extra-cflags=-DGLIB_STATIC_COMPILATION --prefix=/home/u/Desktop/_working/workdir/win64_output/ffmpeg_git_3333.installed --disable-shared --enable-static
libavutil 56. 66.100 / 56. 66.100
libavcodec 58.125.101 / 58.125.101
libavformat 58. 68.100 / 58. 68.100
libavdevice 58. 12.100 / 58. 12.100
libavfilter 7.107.100 / 7.107.100
libswscale 5. 8.100 / 5. 8.100
libswresample 3. 8.100 / 3. 8.100
libpostproc 55. 8.100 / 55. 8.100

It now occurs on multiple input files.

Whereas an ffmpeg built not long ago "git-2021-02-05-cba716f" and all versions prior yield none of those errors, eg

ffmpeg version git-2021-02-05-cba716f-Hydra3333/python_cross_compile_script_v100/3333 Copyright (c) 2000-2021 the FFmpeg developers

built with gcc 10.1.0 (GCC)
configuration: --prefix=/home/u/Desktop/_working/workdir/win64_output/ffmpeg_git_3333.installed --disable-shared --enable-static --arch=x86_64 --target-os=mingw64 --cross-prefix=x86_64-w64-mingw32- --pkg-config=pkg-config --pkg-config-flags=--static --disable-shared --enable-static --disable-w32threads --enable-pthreads --enable-cross-compile --target-exec=wine --enable-runtime-cpudetect --enable-gpl --enable-version3 --extra-version=Hydra3333/python_cross_compile_script_v100/3333 --enable-pic --enable-bzlib --enable-zlib --enable-lzma --disable-fontconfig --disable-libfontconfig --disable-libfreetype --disable-libfribidi --disable-libbluray --disable-libcdio --enable-avisynth --enable-vapoursynth --disable-librtmp --disable-libcaca --enable-iconv --enable-libxml2 --enable-gmp --enable-gnutls --enable-libzimg --enable-libx264 --enable-libx265 --enable-libvpx --enable-libdav1d --enable-libaom --enable-libxvid --enable-gray --enable-libopus --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libsoxr --enable-librubberband --disable-libass --enable-libwebp --enable-ffnvcodec --enable-cuvid --enable-cuda-llvm --disable-opengl --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --disable-libmfx --disable-amf --disable-opencl --extra-libs='-lpsapi -lintl -liconv -lssp' --enable-nonfree --enable-libfdk-aac --disable-decklink --enable-libtwolame --enable-libzvbi --enable-libgsm --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-libsnappy --disable-frei0r --enable-libsrt --enable-libbs2b --enable-libilbc --disable-libgme --disable-libflite --enable-sdl2 --enable-libopenmpt --enable-libmysofa --enable-libvidstab --disable-libmodplug --disable-schannel --extra-cflags=-DLIBTWOLAME_STATIC --extra-cflags=-DMODPLUG_STATIC --extra-cflags=-DLIBXML_STATIC --extra-cflags=-DGLIB_STATIC_COMPILATION --prefix=/home/u/Desktop/_working/workdir/win64_output/ffmpeg_git_3333.installed --disable-shared --enable-static
libavutil 56. 64.100 / 56. 64.100
libavcodec 58.120.100 / 58.120.100
libavformat 58. 66.100 / 58. 66.100
libavdevice 58. 11.103 / 58. 11.103
libavfilter 7.102.100 / 7.102.100
libswscale 5. 8.100 / 5. 8.100
libswresample 3. 8.100 / 3. 8.100
libpostproc 55. 8.100 / 55. 8.100

How to reproduce:

% ffmpeg -i input ... output
"C:\SOFTWARE\Vapoursynth-x64\ffmpeg.exe" -hide_banner -v verbose -nostats -f vapoursynth -i "D:\VRDTVSP-SCRATCH\some_file.2021-02-05.QSF.vpy" -probesize 120M -analyzeduration 120M  -i "D:\VRDTVSP-SCRATCH\some_file.2021-02-05.QSF.mpg" -map 0:v:0 -map 1:a:0 -vf "setdar=16/9" -vsync 0 -sws_flags lanczos+accurate_rnd+full_chroma_int+full_chroma_inp -strict experimental -c:v h264_nvenc -pix_fmt nv12 -preset p7 -multipass fullres -forced-idr 1 -g 25 -spatial-aq 1 -temporal-aq 1 -refs 3 -rc:v vbr -cq:v 0 -b:v 2000000 -minrate:v 100000 -maxrate:v 4000000 -bufsize 4000000 -profile:v high -level 5.2 -movflags +faststart+write_colr -af "adelay=delays=9ms:all=1" -c:a libfdk_aac -cutoff 20000 -ab 256k -ar 48000  -y "G:\HDTV\000-TO-BE-PROCESSED\zzz-TEST\VRDTVSP-Converted\some_file.2021-02-05.mp4" 


built on ... latest git head 2021.02.27

Attachments (1)

command_and_uncut_console_log.txt (55.2 KB ) - added by hydra3333 16 months ago.
command and uncut console log

Download all attachments as: .zip

Change History (16)

comment:1 by hydra3333, 16 months ago

PS I'm not sure what is being replaced by a "guess" nor what the guess is.

comment:2 by Carl Eugen Hoyos, 16 months ago

Resolution: needs_more_info
Status: newclosed

comment:3 by hydra3333, 16 months ago

Resolution: needs_more_info
Status: closedreopened

ok, what more info would you like to see ?
Happy to provide if I knew what it was.

comment:4 by Carl Eugen Hoyos, 16 months ago

Resolution: needs_more_info
Status: reopenedclosed

At least the command line you tested together with the complete, uncut console output and an input sample are missing.
Do not use hide_banner unless you want to report an issue with this option.

comment:5 by Balling, 16 months ago

Maybe because of a0949d0bcb0eee2f3fffcf9a4810c0295d14c0dc? Try to revert it. It could be triggering it because of FIXIT 7a2d94cf1ade02829b36f9ebc8d6bb2e6e126343!

Actually after further looking into this issue, that guessing may work as intended, though it may be good to silence this BS. https://github.com/FFmpeg/FFmpeg/commit/9ce7de903882793749abc68eeb29813a19f50de5#comments

Last edited 16 months ago by Balling (previous) (diff)

comment:6 by hydra3333, 16 months ago

Thank you, Bailing.

Given what you say, I reckon I'll leave this ticket closed and live with the output unless I see an issue.

I hope the messages can be somehow quieted a bit :)

by hydra3333, 16 months ago

command and uncut console log

comment:7 by hydra3333, 16 months ago

Resolution: needs_more_info
Status: closedreopened

OK, in the interests of perhaps something to possibly reduce the number of messages in the output log that one needs to wade through after running ffmpeg,

Please note that absence of "-v verbose" yields that same long result as with that option.

Thank you for your patience.

comment:8 by Balling, 16 months ago

I do not understand why you are using -refs, there is no such option anymore. It is now called -dpb_size. https://trac.ffmpeg.org/ticket/7303#comment:3

Also, -bf 0 will force B-frames off after a0949d0bcb0eee2f3fffcf9a4810c0295d14c0dc.

comment:9 by hydra3333, 16 months ago

eek, thank you Bailing.
commandline copied from an older script and not changed :(

Apart from DTS, is there some reason one should have b-frames off ?
I understand b-frames minimise the resulting filesize.

comment:10 by Balling, 16 months ago

is there some reason one should have b-frames off

So that you will not have to compile it anew while reverting that commit.

Last edited 16 months ago by Balling (previous) (diff)

comment:11 by Balling, 16 months ago

Status: reopenedopen

Yes, that is the problem in a0949d0bcb0eee2f3fffcf9a4810c0295d14c0dc. It can be reproduced by "-bf -1" (which is a new default, LOL, after that commit), but it is good with -bf 0 and -bf 1, etc.

Last edited 16 months ago by Balling (previous) (diff)

comment:12 by hydra3333, 16 months ago

Thank you.

Ah, yes, the log messages go away with "-dpb_size 0 -bf:v 3 -b_ref_mode:v 0"

just for future reference when any newbies see this, ffmpeg help says
-dpb_size 0 is auto
-b_ref_mode:v 0 means B frames will not be used for reference

Last edited 16 months ago by hydra3333 (previous) (diff)

comment:13 by Carl Eugen Hoyos, 16 months ago

Keywords: nvenc added; DTS removed

comment:15 by Balling, 16 months ago

Resolution: fixed
Status: openclosed
Note: See TracTickets for help on using tickets.