#9027 closed defect (invalid)

Missing frame when decoding

Reported by: Phil Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: mov edts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

The following video clip has a missing frame when trying to decode using windows versions.

https://www.dropbox.com/s/it3x8tcx17ew4m8/Clip%20JVC%20Porto.mp4?dl=0

The number of frames should be 1068 whilst only 1067 can be decoded. I do not have the ability to generate the problem and if I try to subclip then I lose the problem.

I think this is a regression between

libavutil 55. 4.100 / 55. 4.100
libavcodec 57. 10.100 / 57. 10.100
libavformat 57. 11.100 / 57. 11.100
libavdevice 57. 0.100 / 57. 0.100
libavfilter 6. 14.100 / 6. 14.100
libswscale 4. 0.100 / 4. 0.100
libswresample 2. 0.100 / 2. 0.100
libpostproc 54. 0.100 / 54. 0.100

and

libavutil 55. 24.100 / 55. 41.101
libavcodec 57. 46.100 / 57. 66.108
libavformat 57. 37.101 / 57. 58.101
libavdevice 57. 0.101 / 57. 2.100
libavfilter 6. 46.101 / 6. 67.100
libswscale 4. 1.100 / 4. 3.101
libswresample 2. 1.100 / 2. 4.100

It may be due to the frame ordering, starting with IBBPBB in stream order but is BBIBBP in presentation order.

How to reproduce info stating frames = 1067:

% ffmpeg.exe -y  -i "Clip JVC Porto.mp4" -f null -

How to reproduce extraction of empty frame:

ffmpeg" -i "Clip JVC Porto.mp4" -vf "select=eq(n\,1067)" -vframes 1 out.bmp

Attachments (1)

log.txt (570.0 KB ) - added by Phil 19 months ago.
output from ffmpeg -v 9 -loglevel 99 -i

Download all attachments as: .zip

Change History (2)

by Phil, 19 months ago

Attachment: log.txt added

output from ffmpeg -v 9 -loglevel 99 -i

comment:1 by Carl Eugen Hoyos, 19 months ago

Keywords: mov edts added
Resolution: invalid
Status: newclosed

Use -ignore_editlist 1 to output all frames.

Note: See TracTickets for help on using tickets.