Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#8923 closed defect (invalid)

Decklink functions in FFmpeg not working anymore after SDK update to 11.6

Reported by: Florian Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: decklink
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I am using the "media-autobuild_suite" to build FFmpeg with Decklink functions.
I recently tested my newest build (on October 2nd) from the git-master and tested the basic functionalities.

Output of "ffmpeg -hide_banner -sources decklink" with a decklink in my computer and the latest build:

Auto-detected sources for decklink:

It should look like this - from the build from September 8th:

Auto-detected sources for decklink:
  73:18622632:00000000 [DeckLink 4K Extreme 12G]

When this basic function is not working, none of them are.

Between those two builds was the update to the SDK 11.6.
Is this a bug in FFmpeg or in the SDK? Thanks for looking into it.

More informations can be found here:
https://github.com/m-ab-s/media-autobuild_suite/issues/1824

Change History (5)

comment:1 by Marton Balint, 13 months ago

Does ffmpeg -sinks work? Does it make a difference if you change duplex mode in the control panel?

comment:2 by Florian, 13 months ago

ffmpeg -sinks

ffmpeg version N-99452-g41b5fddffb-ga191d4166f+3 Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 10.2.0 (Rev3, Built by MSYS2 project)
  configuration:  --cc='ccache gcc' --cxx='ccache g++' --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --enable-ffnvcodec --enable-nvdec --enable-cuda-llvm --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libx264 --enable-libx265 --enable-libdav1d --enable-libaom --disable-debug --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwavpack --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libopenmpt --enable-version3 --enable-librav1e --enable-libsrt --enable-libgsm --enable-libvmaf --enable-libsvtav1 --enable-chromaprint --enable-decklink --enable-frei0r --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libfdk-aac --enable-libflite --enable-libfribidi --enable-libgme --enable-libilbc --enable-libsvthevc --enable-libsvtvp9 --enable-libkvazaar --enable-libmodplug --enable-librtmp --enable-librubberband --enable-libtesseract --enable-libxavs --enable-libzmq --enable-libzvbi --enable-openal --enable-libcodec2 --enable-ladspa --enable-libglslang --enable-vulkan --enable-opencl --enable-opengl --enable-libopenh264 --enable-openssl --extra-cflags=-fopenmp --extra-libs=-lgomp --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DCACA_STATIC --extra-cflags=-DMODPLUG_STATIC --extra-cflags=-DCHROMAPRINT_NODLL --extra-libs=-lstdc++ --extra-cflags=-DZMQ_STATIC --extra-libs=-lpsapi --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv --disable-w32threads --extra-cflags=-DKVZ_STATIC_LIB --enable-nonfree --extra-cflags=-DAL_LIBTYPE_STATIC --extra-cflags='-IC:/Development/MABS_All/local64/include/AL'
  libavutil      56. 60.100 / 56. 60.100
  libavcodec     58.108.100 / 58.108.100
  libavformat    58. 59.100 / 58. 59.100
  libavdevice    58. 11.102 / 58. 11.102
  libavfilter     7. 87.100 /  7. 87.100
  libswscale      5.  8.100 /  5.  8.100
  libswresample   3.  8.100 /  3.  8.100
  libpostproc    55.  8.100 / 55.  8.100

Device name is not provided.
You can pass devicename[,opt1=val1[,opt2=val2...]] as an argument.

Auto-detected sinks for caca:
Cannot list sinks. Not implemented.
Auto-detected sinks for decklink:
Auto-detected sinks for opengl:
Cannot list sinks. Not implemented.
Auto-detected sinks for sdl,sdl2:
Cannot list sinks. Not implemented.

I don't know what you mean with "change duplex mode in the control panel".

comment:3 by Marton Balint, 13 months ago

Duplex mode is the ablity to specify if a connector is used for input or output. I don't remember, maybe you can set it by choosing the connector in the Connectors tab of the Blackmagic Desktop Video Setup in the Windows Control Panel.

But considering that neither the sinks are shown, the obvious question is: Have you updated he Decklink Drivers to 11.6 in the machine you are testing the executable built against 11.6?

comment:4 by Florian, 13 months ago

Resolution: invalid
Status: newclosed

Duplex mode seems not supported by my card. There was no option in the Desktop Video Setup for this.

Funny story, I had not updated the drivers of the Blackmagic card.
I did so now and the ffmpeg -sinks command brings up my card. So, and this is a little embarassing, I am sorry for opening this issue. :/

comment:5 by Marton Balint, 13 months ago

No worries, I guess a warning should be shown if an older library is detected than what the binary is built against, because you are not the first to make this mistake.

Note: See TracTickets for help on using tickets.