#8852 closed enhancement (invalid)

Can you provide official builds with libnpp on Windows?

Reported by: axfelix Owned by:
Priority: wish Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

I notice you aren't currently providing official builds on Windows with --enable-libnpp, which notably makes it impossible to use both GPU decoding and GPU encoding in the same ffmpeg run, due to needing to provide scaling parameters in that case like so: vf "hwupload_cuda,scale_npp=w=1280:h=-2", per this ticket: https://trac.ffmpeg.org/ticket/5587.

Is it possible to provide builds with libnpp on Windows currently, or is this a CUDA limitation?

Change History (2)

comment:1 by Balling, 14 months ago

This would be very nice, but the simple answer is that it is illegal to do so, see my https://github.com/rdp/ffmpeg-windows-build-helpers/issues/430#issuecomment-590142076

comment:2 by Carl Eugen Hoyos, 14 months ago

Component: build systemundetermined
Keywords: windows removed
Resolution: invalid
Status: newclosed
Version: 4.2unspecified

The FFmpeg project does not provide any binaries, only source code.

Note: See TracTickets for help on using tickets.