Opened 2 years ago

Closed 2 years ago

#8817 closed defect (invalid)

Latest static build fails with "Unknown input format: pulse'"

Reported by: John Rose Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Using FFmpeg 4.3.1 (extracted from downloaded ffmpeg-release-amd64-static)from https://johnvansickle.com/ffmpeg/
gives "Unknown input format: 'pulse'"

Terminal input was:
bin/ffmpeg -r 25 -video_size 1920x1080 -f x11grab -draw_mouse 0 -show_region 1 -i :0.0 -f pulse -ac 2 -i default -vcodec libx265 -y /home/john/Temporary/v.mp4 >/home/john/Temporary/l.txt 2>&1

Attachments (1)

l.txt (1.5 KB ) - added by John Rose 2 years ago.
Standard output & standard error

Download all attachments as: .zip

Change History (3)

by John Rose, 2 years ago

Attachment: l.txt added

Standard output & standard error

comment:1 by John Rose, 2 years ago

Is this because libpulse codec is not enabled in ffmpeg (release 4.3.1 amd64) at the static builds available at https://johnvansickle.com/ffmpeg/ ?

comment:2 by Carl Eugen Hoyos, 2 years ago

Resolution: invalid
Status: newclosed

This cannot be fixed in the FFmpeg source code.

Note: See TracTickets for help on using tickets.