#8810 closed defect (invalid)

Compilation FFmpeg fails

Reported by: John Rose Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: danregister@poczta.fm Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Tried to compile FFmpeg (on Ubuntu 18.04) using instructions at: https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

Source was obtained from link https://johnvansickle.com/ffmpeg/builds/ffmpeg-git-amd64-static.tar.xz

All well until "ERROR: gnutls not found using pkg-config".

Terminal output attached.

Attachments (3)

FFmpeg Compilation Terminal output.txt (301.7 KB ) - added by John Rose 15 months ago.
Terminal output
ffmpeg_configure_output.txt (1.2 KB ) - added by Artem 14 months ago.
Dockerfile (4.7 KB ) - added by Artem 14 months ago.
Simple docker file compiled from ffmpeg manual to reproduce an issue

Download all attachments as: .zip

Change History (11)

by John Rose, 15 months ago

Terminal output

comment:1 by Carl Eugen Hoyos, 15 months ago

Keywords: gnutls removed
Resolution: invalid
Status: newclosed

Please ask all usage questions on the user mailing list but please understand that we do not support third-party scripts.

comment:2 by John Rose, 15 months ago

This script (i.e. procedure) was the one on trac.ffmpeg.org website (i.e. this one):

https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

comment:3 by John Rose, 15 months ago

Resolution: invalid
Status: closedreopened

This script (i.e. procedure) was the one on trac.ffmpeg.org website (i.e. this one):

https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

comment:4 by Carl Eugen Hoyos, 15 months ago

Resolution: invalid
Status: reopenedclosed

by Artem, 14 months ago

Attachment: ffmpeg_configure_output.txt added

comment:5 by Artem, 14 months ago

Resolution: invalid
Status: closedreopened

While that looks like 3rd party software issue at a glance it does not seem so after closer check.
It looks like something with configure script. Please check attachment ffmpeg_configure_output.txt​ which shows the actual configure error.
Just to be clear gnutls is installed and pkg-config test passes but script fails on later stages (check_func_headers).
You could also check a simple docker file (attached) which reproduces the issue. That is just "compilation" of commands presented on "compilation guide" page.

by Artem, 14 months ago

Attachment: Dockerfile added

Simple docker file compiled from ffmpeg manual to reproduce an issue

comment:6 by danadam, 10 months ago

In my case (Debian Testing) I have:

/usr/bin/ld: cannot find -lunistring
collect2: error: ld returned 1 exit status
ERROR: gnutls not found using pkg-config

In gnutls.pc there is:

Libs: -L${libdir} -lgnutls
Libs.private:    -pthread   -lgmp -lunistring -latomic

The --pkg-config-flags="--static" option to configure makes it use "Libs.private" line, so it tries to link with unistring. The problem is that "libgnutls28-dev" does not depend on "libunistring-dev".

I removed the option and it fixed the issue. I suspect that manually installing "libunistring-dev" would also fix it, although I found this regarding static linking of gnutls: https://gitlab.com/gnutls/gnutls/-/issues/203

Nikos Mavrogiannopoulos @nmav · 3 years ago

Note that static linking applications with gnutls is not something supported. gnutls relies on library constructors and destructors which are not loaded when linking statically.

Last edited 10 months ago by danadam (previous) (diff)

comment:7 by danadam, 10 months ago

Cc: danregister@poczta.fm added

comment:8 by Carl Eugen Hoyos, 10 months ago

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.