Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#8793 closed enhancement (fixed)

Add 'peak' mode to showwavespic

Reported by: MelkorLord Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It would be very nice to have a 'peak' mode in showwavespic. Currently, showwavespic only supports the average RMS to render the waveform if I'm not mistaken. At least it really looks like Audacity's light blue part of the waveform here - https://manual.audacityteam.org/man/audio_tracks.html#stereo.

A new option in showwavespic to use the 'peak' level for rendering the waveform would be really nice as it is very helpful in my use cases. Thank you.

Attachments (5)

showwavespic_test_sample_drawscale.png (82.2 KB ) - added by MelkorLord 2 years ago.
showwavespic_test_sample_drawscale.2.png (82.2 KB ) - added by MelkorLord 2 years ago.
showwavespic_test_sample_drawfull.png (82.2 KB ) - added by MelkorLord 2 years ago.
showwavespic_test_sample_audacity.png (36.6 KB ) - added by MelkorLord 2 years ago.
showwavespic_test_sample_soundforge.png (31.3 KB ) - added by MelkorLord 2 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by Elon Musk, 2 years ago

Resolution: invalid
Status: newclosed

Try draw=full option.

by MelkorLord, 2 years ago

by MelkorLord, 2 years ago

by MelkorLord, 2 years ago

by MelkorLord, 2 years ago

by MelkorLord, 2 years ago

comment:2 by MelkorLord, 2 years ago

I don't think "draw=full" is the right answer. Please see the attached waveforms to see the difference.

SoundForge (Windows) only supports peak level display and the waveform is identical to Audcacity's dark blue part.

Audacity displays both peak (dark blue) and average RMS (light blue) and the light blue part is quite identical to FFMPEG's showwavespic overall shape.

Besides, there's no apparent difference between "draw=scale" and "draw=full" options, at least not using this resolution. Using higher resolutions (tested up to 3840 pixels width) shows differences but the waveform aspect remains the same, only more detailed as the "draw=full" seems to imply.

If you need the OGG Vorbis sample, just ask but I'll have to compress it further because it's a bit bigger than the allowed attachment size (2.5 MB vs 3.9 MB for the OGG file)

comment:3 by MelkorLord, 2 years ago

Sorry for attachment showwavespic_test_sample_drawscale.2.png which was a misfire, it's the same as showwavespic_test_sample_drawscale.png

comment:4 by MelkorLord, 2 years ago

Resolution: invalid
Status: closedreopened

Sorry to reopen but I really think it still needs further discussion.

A 'peak' view like in SoundForge and Audacity is very useful for several reasons. At least to me (and other music collectors) to spot music tracks which were processed through dynamic compressors when mixed in the studio. This is especially important for remasters and/or reissues of old material when dynamic compressors weren't the norm, what is nowadays called the loudness war - https://en.wikipedia.org/wiki/Loudness_war

It would be really nice to have this feature available. Thank you.

comment:5 by Elon Musk, 2 years ago

Resolution: fixed
Status: reopenedclosed

Please refrain to re-open closed tickets, there is no discussion about this.
Feature is already available.

comment:6 by MelkorLord, 2 years ago

No it's not, there is sufficient evidence in the attached files to prove that but ok, you win, I give up.

There is no worse blind man than the one who doesn't want to see

as they say.

Note: See TracTickets for help on using tickets.