Opened 2 years ago

Closed 2 years ago

#8756 closed enhancement (duplicate)

libavformat/avisynth.c does not set interlacing and field order

Reported by: emcodem Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When using avisynth source (.avs files), the interlacement and field order is not being set. I believe st->codec->field_order could be set around line 120 in avisynth.c, based on the avisynth values int avs_is_field_based
int avs_is_parity_known
int avs_is_bff
int avs_is_tff

How to reproduce:
ffmpeg:

% ffprobe.exe -read_intervals "%+#2" -show_entries "frame=interlaced_frame,tff" -pretty -print_format json -of json   test.avs

avisynth test.avs script:

colorbarshd()
assumefieldbased()
assumetff()

Change History (1)

comment:1 by mkver, 2 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #8757.

Note: See TracTickets for help on using tickets.