#8670 closed defect (duplicate)

scale/rate is 1/0 which is invalid

Reported by: Anatoly Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: avi regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Error when converting avi file without audio stream to mp4.
File is produced by mobile DVR.
When file contains audio stream then converting works perfectly.

How to reproduce:

ffmpeg.exe -i 1.avi -vcodec copy 1.mp4
ffmpeg version 4.2.2 
built on 2020-01-22

E:\2>ffmpeg.exe -i 1.avi -vcodec copy 1.mp4
ffmpeg version 4.2.2 Copyright (c) 2000-2019 the FFmpeg developers

built with gcc 9.2.1 (GCC) 20200122
configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libdav1d --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth --enable-libopenmpt
libavutil 56. 31.100 / 56. 31.100
libavcodec 58. 54.100 / 58. 54.100
libavformat 58. 29.100 / 58. 29.100
libavdevice 58. 8.100 / 58. 8.100
libavfilter 7. 57.100 / 7. 57.100
libswscale 5. 5.100 / 5. 5.100
libswresample 3. 5.100 / 3. 5.100
libpostproc 55. 5.100 / 55. 5.100

[avi @ 0000013b44d29500] scale/rate is 1/0 which is invalid. (This file has been generated by broken software.)
[avi @ 0000013b44d29500] Invalid sample rate: 0
1.avi: Invalid data found when processing input

Attachments (1)

1.avi (237.2 KB ) - added by Anatoly 17 months ago.

Download all attachments as: .zip

Change History (2)

by Anatoly, 17 months ago

Attachment: 1.avi added

comment:1 by Carl Eugen Hoyos, 17 months ago

Component: ffmpegavformat
Keywords: avi regression added
Resolution: duplicate
Status: newclosed
Version: 4.2git-master

Duplicate of ticket #5771.

Note: See TracTickets for help on using tickets.