Opened 3 years ago

Closed 3 years ago

#8602 closed defect (invalid)

Configure gives nonsense error at "freetype2 not found" when missing other packages instead

Reported by: php4fan Owned by:
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:
Follow the instructions at https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

I get this error:
ERROR: freetype2 not found using pkg-config

Either something is broken or the installation instructions are incomplete.

(I'm selecting "build system" as the component. If something is missing from the above guide, then it should be "documentation")

I already searched and found age-old threads mentioning the very same issuem, but they all claim it's fixed and no working solution is mentioned.

Change History (3)

comment:1 by php4fan, 3 years ago

Priority: criticalnormal
Summary: Can't compile following instructions: ERROR: freetype2 not found using pkg-configConfigure gives nonsense error at "freetype2 not found" when missing other packages instead

Actually I was missing libass-dev. That was my bad.
However I'd expect a more precise error message.

After installing that, I got the (this time expected) error message that I was also missing libvorbis.

comment:2 by James, 3 years ago

You got that error because the freetype2 pkg-config check failed. The details of the error are in the config.log file generated by configure.

If you can re-run it in order to trigger the same failure again, looking at that file would help to know why missing libass affected it.

comment:3 by Carl Eugen Hoyos, 3 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.