Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#86 closed defect (fixed)

aasc codec regression

Reported by: ami_stuff Owned by:
Priority: important Component: avfilter
Version: git Keywords: aasc
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

aasc video codec regression - reproductable with ffmpeg & ffplay
(yellow lines at the top of the video)

most likely another libavfilter-caused regression

http://samples.multimedia.cx/V-codecs/AASC/AASC.AVI

C:\>ffmpeg -i C:\AASC.AVI
FFmpeg version git-N-29181-ga304071, Copyright (c) 2000-2011 the FFmpeg develope
rs
  built on Apr 18 2011 21:24:03 with gcc 4.5.2
  configuration: --enable-gpl --enable-version3 --enable-runtime-cpudetect --ena
ble-memalign-hack --enable-avisynth --enable-bzlib --enable-frei0r --enable-libo
pencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --
enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger
 --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enabl
e-libx264 --enable-libxavs --enable-libxvid --enable-zlib --cross-prefix=i686-w6
4-mingw32- --target-os=mingw32 --arch=x86_32 --extra-cflags=-I/home/kyle/softwar
e/ffmpeg/external-libraries/win32/include --extra-ldflags=-L/home/kyle/software/
ffmpeg/external-libraries/win32/lib --pkg-config=pkg-config
  libavutil    50. 40. 1 / 50. 40. 1
  libavcodec   52.120. 0 / 52.120. 0
  libavformat  52.108. 0 / 52.108. 0
  libavdevice  52.  4. 0 / 52.  4. 0
  libavfilter   1. 79. 0 /  1. 79. 0
  libswscale    0. 13. 0 /  0. 13. 0
Input #0, avi, from 'C:\AASC.AVI':
  Duration: 00:00:04.52, start: 0.000000, bitrate: 25252 kb/s
    Stream #0.0: Video: aasc, bgr24, 320x175, 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

Change History (4)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avfilter
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git

avfilter-caused regression.

comment:2 Changed 5 years ago by ami_stuff

This seems to be fixed recently as well (please compare the output from libavfilter and non-libavfilter ffmpeg build (with filedup tool) and if the files are identical, close this bug report).

comment:3 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

comment:4 Changed 5 years ago by cehoyos

  • Keywords aasc added
Note: See TracTickets for help on using tickets.