Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#858 closed enhancement (wontfix)

replace the current ALAC code with the ALAC code from Apple

Reported by: ffmpeguser Owned by:
Priority: normal Component: undetermined
Version: Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Change History (4)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

We like the LGPL v2.

Please do report all issues you have with FFmpeg's alac implementation, I don't think any tickets are currently open!

comment:2 Changed 5 years ago by ffmpeguser

what is the problem with the Apache license?

comment:3 Changed 5 years ago by cehoyos

The Apache license is not compatible with the (L)GPL v2.

comment:4 Changed 5 years ago by reimar

Also a standard without at least a second independent implementation is not a standard but a joke.
So removing the only (major?) alternative implementation I know of sure isn't a good idea.
That is ignoring the fact that the Apple code neither fits into the FFmpeg framework nor follows our coding standard.
I at least do not know about the code quality, does the Apple code work on bigendian (probably yes)? On CPUs which do not support unaligned reads/writes (slightly less likely)?
Supporting an external library based on Apple's code like we do for Vorbis and others of course would be possible, if someone feels motivated to do that (and if/when such a library exists).

Note: See TracTickets for help on using tickets.