Opened 3 years ago

Closed 3 years ago

#8545 closed defect (invalid)

AMF PNG FRAMES TO MP4 FILE

Reported by: Victor Augusto Tedesco Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: AMF
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

AMF cannot convert PNG frames to a MP4 video, but it can convert JPG frames to a MP4 video.

Using the command:
ffmpeg -i Camille%04d.png -codec h264_amf -cbr 0 Test.mp4

Getting the console error:
Stream mapping:

Stream #0:0 -> #0:0 (png (native) -> h264 (h264_amf))

Press [q] to stop, ? for help
Output #0, mp4, to 'Test.mp4':

Metadata:

encoder : Lavf58.39.101
Stream #0:0: Video: h264 (h264_amf) (avc1 / 0x31637661), yuv420p, 2560x1440 [SAR 1:1 DAR 16:9], q=-1--1, 2000 kb/s, 25 fps, 12800 tbn, 25 tbc
Metadata:

encoder : Lavc58.73.102 h264_amf

[h264_amf @ 00000250369f3700] SubmitInput() failed with error 29
Video encoding failed
Conversion failed!

Using Windows 10, a R7 260X (Has support to AMF), and using the version: ffmpeg version git-2020-02-27-9b22254

Attachments (1)

ffmpeg-20200301-093555.log (52.0 KB ) - added by Victor Augusto Tedesco 3 years ago.
FFMPEG Log

Download all attachments as: .zip

Change History (3)

by Victor Augusto Tedesco, 3 years ago

Attachment: ffmpeg-20200301-093555.log added

FFMPEG Log

comment:1 by Carl Eugen Hoyos, 3 years ago

Component: ffmpegundetermined
Keywords: AMD removed

Please show the working command line together with the complete, uncut console output.

comment:2 by Victor Augusto Tedesco, 3 years ago

Resolution: invalid
Status: newclosed

My GPU doesn´t support 1440p encoding because it has VCE 2.0, which only support at a maximum of 1920x1920, i discovered a hour ago

Note: See TracTickets for help on using tickets.