Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8510 closed enhancement (needs_more_info)

Allow specifying of audio metadata's encoding.

Reported by: Arimil Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It would be nice if you could specify the encoding used to read in metadata, I've had a few files that I unfortunately can't share where the encoding used to save the metadata is Shift-JIS. When ffmpeg copies this metadata over it converts it to garbage as seen here:

https://pastebin.com/raw/dGZ5DJYU

Change History (2)

comment:1 by Arimil, 3 years ago

Resolution: fixed
Status: newclosed

Looks like this is actually possible already:

ffmpeg -i sample.wav -f ffmetadata - | iconv -f sjis -t utf8 | ffmpeg -i sample.wav -f ffmetadata -i - -map_metadata 1 -c:a flac sample.flac

The above was given to me by furq in the ffmpeg irc and converts the above file correctly.

comment:2 by Carl Eugen Hoyos, 3 years ago

Resolution: fixedneeds_more_info

Feel free to reopen if you can provide the input sample.

Note: See TracTickets for help on using tickets.