Opened 5 years ago

Closed 4 years ago

#848 closed enhancement (wontfix)

expand -formats/-codecs options

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg -codecs - would list everything
ffmpeg -codecs:a:e - would list only audio encoders
ffmpeg -codecs:a:d - would listonly audio decoders
ffmpeg -codecs:v:e - would list only video encoders
ffmpeg -codecs:v:d - would listonly video decoders

ffmpeg -formats - would list everything
ffmpeg -formats:a:d - mould list only audio demuxers
ffmpeg -formats:a:m - mould list only audio muxers
ffmpeg -formats:v:d - mould list only video demuxers
ffmpeg -formats:v:m - mould list only video muxers

Change History (5)

comment:1 Changed 5 years ago by ami_stuff

correction:

ffmpeg -formats:d - would list only demuxers
ffmpeg -formats:m - would list only muxers

comment:2 Changed 5 years ago by saste

  • Type changed from defect to enhancement

comment:3 Changed 4 years ago by michael

in case someone stumbles across this ticket in the search of a workaround/solution
its quite easy to achive this by using for example
ffmpeg -codecs | grep '.D.A'
instead of
ffmpeg -codecs:a:d

Version 0, edited 4 years ago by michael (next)

comment:4 Changed 4 years ago by saste

What's wrong about using grep?

Also I'm slightly against adopting a syntax resembling the one for stream selection, but with different features and warts, so I'd rather stick with easy grep parsing rather than bloat the code with features which can be implemented with simple scripting.

comment:5 Changed 4 years ago by ami_stuff

  • Resolution set to wontfix
  • Status changed from new to closed

Ok, I will close this ticket then (there seems to be also -decoders and -encoders options which I did not notice before).

Note: See TracTickets for help on using tickets.