Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#8480 closed defect (duplicate)

tpad filter doesn't work with -r on input

Reported by: occvtech Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

The tpad filter does not work properly when the command includes a frame rate change on the input file via -r. More specifically, if a command includes a -r flag to change the framerate on the input file, and that command includes the tpad filter, then the output will end up not honoring the requested pad duration, and instead will hold the last frame for a really long (arbitrary time), and throw an error saying "More than 1000 frames duplicated'.

Command example:

ffmpeg -r 15 -i INPUT -filter_complex "[0:v]tpad=stop_duration=5[out]" -map [out] OUTPUT


....If instead, I remove the -r 15, and use the -framerate flag or the frame rate filter instead, then the command appears to work properly.


Full console output:

built with gcc 9.2.1 (GCC) 20191010
configuration: --disable-static --enable-shared --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libdav1d --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth --enable-libopenmpt --enable-amf
libavutil 56. 35.101 / 56. 35.101
libavcodec 58. 62.100 / 58. 62.100
libavformat 58. 35.100 / 58. 35.100
libavdevice 58. 9.100 / 58. 9.100
libavfilter 7. 66.100 / 7. 66.100
libswscale 5. 6.100 / 5. 6.100
libswresample 3. 6.100 / 3. 6.100
libpostproc 55. 6.100 / 55. 6.100
Input #0, h264, from 'D:\test.264':
Duration: N/A, bitrate: N/A
Stream #0:0: Video: h264 (Constrained Baseline), yuv420p(progressive), 352x240, 25 fps, 25 tbr, 1200k tbn, 50 tbc
Stream mapping:
Stream #0:0 (h264) -> tpad
tpad -> Stream #0:0 (libx264)
Press [q] to stop, ? for help
[libx264 @ 000001ae46a41980] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
[libx264 @ 000001ae46a41980] profile High, level 1.2, 4:2:0, 8-bit
[libx264 @ 000001ae46a41980] 264 - core 158 - H.264/MPEG-4 AVC codec - Copyleft 2003-2019 - ​http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=7 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=15 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'd:\output.mp4':
Metadata:
encoder : Lavf58.35.100
Stream #0:0: Video: h264 (libx264) (avc1 / 0x31637661), yuv420p, 352x240, q=-1--1, 15 fps, 15360 tbn, 15 tbc
Metadata:
encoder : Lavc58.62.100 libx264
Side data:
cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: N/A
More than 1000 frames duplicated
frame=48380 fps=2757 q=-1.0 Lsize= 7491kB time=00:53:45.13 bitrate= 19.0kbits/s dup=47999 drop=0 speed= 184x
video:6924kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 8.188529%
[libx264 @ 000001ae46a41980] frame I:194 Avg QP:14.84 size: 28419
[libx264 @ 000001ae46a41980] frame P:12206 Avg QP:15.96 size: 65
[libx264 @ 000001ae46a41980] frame B:35980 Avg QP:24.33 size: 22
[libx264 @ 000001ae46a41980] consecutive B-frames: 0.8% 0.0% 0.0% 99.1%
[libx264 @ 000001ae46a41980] mb I I16..4: 2.2% 17.6% 80.2%
[libx264 @ 000001ae46a41980] mb P I16..4: 0.0% 0.0% 0.0% P16..4: 0.6% 0.1% 0.1% 0.0% 0.0% skip:99.1%
[libx264 @ 000001ae46a41980] mb B I16..4: 0.0% 0.0% 0.0% B16..8: 0.1% 0.1% 0.0% direct: 0.0% skip:99.8% L0:43.1% L1:45.1% BI:11.9%
[libx264 @ 000001ae46a41980] 8x8 transform intra:17.8% inter:22.9%
[libx264 @ 000001ae46a41980] coded y,uvDC,uvAC intra: 98.5% 65.4% 53.5% inter: 0.1% 0.1% 0.0%
[libx264 @ 000001ae46a41980] i16 v,h,dc,p: 1% 16% 28% 56%
[libx264 @ 000001ae46a41980] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 8% 36% 18% 4% 4% 4% 10% 4% 13%
[libx264 @ 000001ae46a41980] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 10% 31% 12% 5% 5% 5% 12% 5% 15%
[libx264 @ 000001ae46a41980] i8c dc,h,v,p: 37% 33% 18% 13%
[libx264 @ 000001ae46a41980] Weighted P-Frames: Y:0.1% UV:0.0%
[libx264 @ 000001ae46a41980] ref P L0: 82.0% 6.5% 8.4% 2.8% 0.3%
[libx264 @ 000001ae46a41980] ref B L0: 93.7% 5.0% 1.3%
[libx264 @ 000001ae46a41980] ref B L1: 97.3% 2.7%
[libx264 @ 000001ae46a41980] kb/s:17.59

Attachments (1)

testing.264 (1.1 MB) - added by occvtech 3 months ago.
random sample file for testing the tpad filter with a framerate change

Download all attachments as: .zip

Change History (3)

Changed 3 months ago by occvtech

random sample file for testing the tpad filter with a framerate change

comment:1 Changed 3 months ago by richardpl

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8409.

comment:2 Changed 3 months ago by cehoyos

  • Keywords tpad framerate removed
  • Version changed from 4.2 to unspecified
Note: See TracTickets for help on using tickets.