Opened 5 years ago

Closed 4 years ago

#821 closed defect (fixed)

--enable-x11grab doesn't work properly

Reported by: burek Owned by:
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes


I've tried configuring ffmpeg with --enable-x11grab and the configure passed without any errors, but x11 input wasn't enabled (I still had the message "Unknown input format: 'x11grab'" after the building process and even ./configure --enable-x11grab .. | grep x11_grab_device didn't produce any output)

Recommendation is that configure should check if needed libraries are installed for x11 input device to be properly built and if they are not installed, to break out of the configure process with a descriptive error message.

I've solved my problem reading this article:
which basically says that I lacked some libraries (libx11-dev, libxfixes-dev and libxext-dev), and after installing those, I've had x11_grab_device in the list of input devices.

Attachments (1)

patchx11config.diff (437 bytes) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to build system
  • Status changed from new to open

Certain optional components like cdio and zlib do not cause a configure error if they were explicitly requested by the user but are unavailable.

comment:2 Changed 4 years ago by saste

Can't reproduce the error here, indeed configure --enable-x11grab --enable-gpl will fail with an error message telling which component can't be found, as expected.

Different issue if you enable --enable-indev=x11_grab_device.

comment:3 Changed 4 years ago by saste

  • Analyzed by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Was fixed in:

commit 4a584edad7cd9be8241e8b6fe1fadf8340cd292b
Author: Josh Allmann <>
Date:   Wed Mar 21 08:01:37 2012 -0700

    configure: die if x11grab dependencies are unavailable
    Signed-off-by: Diego Biurrun <>
Note: See TracTickets for help on using tickets.