Opened 3 years ago

Closed 17 months ago

Last modified 17 months ago

#8203 closed defect (fixed)

EXR with single zdepth channel read error

Reported by: ils_fl Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: exr regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
Using ffmpeg build N-94300-gaf5f770113
There is an issue reading exr files generated from vray render engine that have a single zdepth channel. However an exr files with two zdepth channels are read without an issue. Important to note is that this error is only caused by vray's zdepth pass, all other passes work fine.

This was not an issue in the previous build N-82143-gbf14393

How to reproduce:
Included are two exr images:
s02-01_Double_.0000.exr and s02-01_Single_.0000.exr
One exr image with a single zdepth pass and another with 2 zdepth passes. Compressing the single exr will create a read error but compressing the double will not. Compressing an exr image without zdepth work as well as compressing exr image with other passes other than zdepth also works. (s02-01_none_.0000.exr and s02-01_all_others_.0000.exr respectivly)

ffmpeg.exe -v 9 -loglevel 99  -f image2  -gamma 2.2 -framerate 24 -y -start_number 0 -i "C:\temp\s02-01\01.Sky\s02-01_double_.0%%03d.exr" -vcodec utvideo -pred left -pix_fmt rgb24 -r 24 "C:\ExportedMOVs\s02-01_sky_d_.avi" 2> "c:\temp\s02-01\log_sky_s.txt"
ffmpeg.exe -v 9 -loglevel 99  -f image2  -gamma 2.2 -framerate 24 -y -start_number 0 -i "C:\temp\s02-01\01.Sky\s02-01_single_.0%%03d.exr" -vcodec utvideo -pred left -pix_fmt rgb24 -r 24 "C:\ExportedMOVs\s02-01_sky_s_.avi" 2> "c:\temp\s02-01\log_sky_d.txt"
built on ...

Attachments (2)

EXR_Compressio_Issue_Zdepth.zip (2.2 MB ) - added by ils_fl 3 years ago.
EXR with zdepth pass from vray read error
s02-01_single_.0000.exr (292.8 KB ) - added by Carl Eugen Hoyos 3 years ago.

Change History (5)

by ils_fl, 3 years ago

EXR with zdepth pass from vray read error

comment:1 by Carl Eugen Hoyos, 3 years ago

Component: undeterminedavcodec
Keywords: exr regression added
Reproduced by developer: set
Version: 4.2git-master

Regression since f9728feaf90eb7493f8872356f54150efafb59cc

$ ffmpeg -i s02-01_single_.0000.exr 
ffmpeg version N-95072-gced3b8c61e Copyright (c) 2000-2019 the FFmpeg developers
  built with clang version 8.0.1 (tags/RELEASE_801/final 366581)
  configuration: --cc=clang --enable-gpl --enable-gnutls --enable-libxml2 --enable-libx264 --enable-libx265 --enable-libvpx --enable-libaom
  libavutil      56. 35.100 / 56. 35.100
  libavcodec     58. 59.100 / 58. 59.100
  libavformat    58. 33.100 / 58. 33.100
  libavdevice    58.  9.100 / 58.  9.100
  libavfilter     7. 59.100 /  7. 59.100
  libswscale      5.  6.100 /  5.  6.100
  libswresample   3.  6.100 /  3.  6.100
  libpostproc    55.  6.100 / 55.  6.100
[exr @ 0x2434b00] Multiple channels with index 2.
[exr_pipe @ 0x2432bc0] decoding for stream 0 failed
[exr_pipe @ 0x2432bc0] Could not find codec parameters for stream 0 (Video: exr, none): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, exr_pipe, from 's02-01_single_.0000.exr':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: exr, none, 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

by Carl Eugen Hoyos, 3 years ago

Attachment: s02-01_single_.0000.exr added

comment:2 by Elon Musk, 17 months ago

Resolution: fixed
Status: newclosed

Not reproducible anymore.

Note: See TracTickets for help on using tickets.