Opened 3 years ago

Closed 3 years ago

#8185 closed defect (invalid)

Create thumbnails from MPEG-DASH stream

Reported by: Jan Živković Owned by:
Priority: normal Component: ffmpeg
Version: git-master Keywords: dash
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I'm trying to process video images with openCV using ffmpeg for capturing of streams and have found an issue with DASH streams. I have also found a working example of DASH stream for reference.

Working DASH stream: http://irtdashreference-i.akamaihd.net/dash/live/901161/bfs/manifestBR.mpd
Not working DASH stream: https://irtdashreference-i.akamaihd.net/dash/live/901161/bfs/manifestARD.mpd

How to reproduce:

  1. Have ffmpeg, any version, reproduced with:
  • latest nightly (N-94982-gea673a0edb) for windows
  • 4.1.4 for windows
  • 3.4.6-0ubuntu0.18.04.1 linux(ubuntu)
  1. Run the provided ffmpeg command
    % ffmpeg -i https://irtdashreference-i.akamaihd.net/dash/live/901161/bfs/manifestARD.mpd -vf fps=1/10 img%03d.jpg
    
  2. ffmpeg starts displaying error messages
    [dash @ 000001520cc98640] No longer receiving stream_index 1
    [dash @ 000001520cc98640] No longer receiving stream_index 2
    [dash @ 000001520cc98640] No longer receiving stream_index 3
    [dash @ 000001520cc98640] No longer receiving stream_index 4
    [dash @ 000001520cc98640] No longer receiving stream_index 5
    [dash @ 000001520cc98640] No longer receiving stream_index 6
    [https @ 000001520d278340] HTTP error 404 Not Found bitrate=N/A speed=16.6x
    [dash @ 000001520cc98640] Failed to open fragment of playlist 0
    [https @ 000001520d277fc0] HTTP error 404 Not Found
    [dash @ 000001520cc98640] Failed to open fragment of playlist 0
    

Using command ffplay with the "not working stream", content plays just fine. There seems to be a problem only with capturing thumbnail images.

ffplay https://irtdashreference-i.akamaihd.net/dash/live/901161/bfs/manifestARD.mpd

Using verbose logs I noticed that ffmpeg was trying to fetch parts of DASH stream not yet made/streamed ie. fetching stream from future. Because there is no content yet, 404 error is output.
If I try the url that returned 404 in chrome (10 sec later) I get the response with movie, but if I try it as soon as the error appears there is no content (404).

I have also attached the report file generated by ffmpeg on latest nightly version for windows.

Attachments (1)

ffmpeg-20190920-115529.log (227.0 KB ) - added by Jan Živković 3 years ago.
ffmpeg command report

Download all attachments as: .zip

Change History (2)

by Jan Živković, 3 years ago

Attachment: ffmpeg-20190920-115529.log added

ffmpeg command report

comment:1 by Carl Eugen Hoyos, 3 years ago

Keywords: stream thumbnail removed
Resolution: invalid
Status: newclosed

Sounds as if this needs -re.

Note: See TracTickets for help on using tickets.