Opened 3 years ago

Closed 3 years ago

#8098 closed defect (duplicate)

DTS audio to .mp4 sets wrong audio Channel(s) to 2

Reported by: Dameos Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When writing a DTS audio track to a .mp4 container ffmpeg reduces the audio channels to 2 instead of keeping the original channels.

Command:

ffmpeg -i C:\ffmpeg\audio.dts -map 0:0 -c copy C:\ffmpeg\audio.mp4

MediaInfo:

General
Complete name                            : C:\ffmpeg\audio.mp4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom (isom/iso2/mp41)
File size                                : 2.26 GiB
Duration                                 : 2 h 28 min
Overall bit rate                         : 2 173 kb/s
Writing application                      : Lavf58.31.104

Audio
ID                                       : 1
Format                                   : DTS
Format/Info                              : Digital Theater Systems
Format profile                           : MA / Core
Codec ID                                 : mp4a-A9
Duration                                 : 2 h 28 min
Bit rate mode                            : Variable / Constant
Bit rate                                 : Unknown / 1 509 kb/s
Nominal bit rate                         : 2 170 kb/s
Channel(s)                               : 2 channels
Channel(s)_Original                      : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 93.750 FPS (512 SPF)
Bit depth                                : 16 bits
Compression mode                         : Lossless / Lossy
Stream size                              : 2.26 GiB (100%)
Default                                  : Yes
Alternate group                          : 1

As you can see all the audio stream data is still being written to the mp4 container, but Channel(s) is reduced to 2.

Change History (2)

comment:1 by Elon Musk, 3 years ago

To make this valid ticket provide ffmpeg output of both input and output file.

comment:2 by Carl Eugen Hoyos, 3 years ago

Component: avcodecundetermined
Keywords: dts channel removed
Resolution: duplicate
Status: newclosed
Version: 4.2unspecified

Looks like ticket #3023

Note: See TracTickets for help on using tickets.