Opened 2 years ago

Last modified 14 months ago

#8086 reopened license violation

Alex Mogurenko violates GPL

Reported by: Kieran Kunhya Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Change History (7)

comment:1 by Carl Eugen Hoyos, 2 years ago

Reproduced by developer: set
Status: newopen

The md5sum of ffmpeg.exe is f9d759ff44418ee1b3805d498abd3226, the binary is based on FFmpeg but contains an additional encoder, no source code visible.

comment:2 by Marton Balint, 2 years ago

That is a shame, as the guy used to send prores patches to ffmpeg-devel. They got ignored unfotunately. Maybe he is willing to disclose the source code.

comment:3 by yagomi, 14 months ago

Resolution: fixed
Status: openclosed

The build has been removed with the author leaving a note on his blog - it could have been a more peaceful resolution, but at least we have arrived at a resolution.

comment:4 by Carl Eugen Hoyos, 14 months ago

Resolution: fixed
Status: closedreopened

The (L)GPL would make no sense if a violation could be solved like this.

Sorry for violating your copyright when I distributed [put your favourite blockbuster here], I stopped doing it as soon as you catched me

Last edited 14 months ago by Carl Eugen Hoyos (previous) (diff)

comment:5 by yagomi, 14 months ago

community-oriented enforcement is more about compliance rather than lawsuits anyway - do you think ffmpeg should sue for the short period of violation? FWIW, there is a cure clause in GPLv3 that instates the license given prompt compliance.

comment:6 by Carl Eugen Hoyos, 14 months ago

I think he should provide the source code and I believe this is a completely reasonable request.

comment:7 by Nicolas George, 14 months ago

At the very least, it is not up to the infringing party, nor anybody outside the project, to decide when the issue is resolved. And “curing” the violation is not done by removing the infringing binary, it is done by obeying the license, i.e. giving the source code under the same license.

Note: See TracTickets for help on using tickets.