Opened 3 years ago

Closed 2 years ago

#8080 closed defect (fixed)

Aborting gnutls https connection cuses infinity loop

Reported by: zaps166 Owned by:
Priority: important Component: avformat
Version: git-master Keywords: gnutls regression
Cc: remitamine Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: Aborting (using "AVIOInterruptCB") gnutls connection causes infinity loop inside do/while loop, "avio_open2()".

Regression since bc1749c6e46099ec85110361dbe6f7994a63040d (ticket #7801)

Change History (1)

comment:1 by Carl Eugen Hoyos, 2 years ago

Keywords: gnutls regression added
Priority: normalimportant
Resolution: fixed
Status: newclosed
Version: 4.2git-master

Fixed by Błażej Szczygieł in 561ba15c973120c9565a8f75a7439f3e8a10e04d

Note: See TracTickets for help on using tickets.