Opened 2 years ago

Closed 2 years ago

#8019 closed defect (duplicate)

Failure to properly find syncword in ADTS after desync

Reported by: ePirat Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffplay aac-denbosch.aac
ffmpeg version 4.1.3 Copyright (c) 2000-2019 the FFmpeg developers
built with Apple LLVM version 10.0.1 (clang-1001.0.46.3)

Leave it play for a while (about 25 seconds) and it will fail to successfully play further, even though the file contains more data. Thats because a de-sync happens and ffmpeg does not properly syncs again on a syncword, so it get garbage data for ADTS headers.

Change History (2)

comment:2 by Carl Eugen Hoyos, 2 years ago

Component: avformatundetermined
Keywords: ADTS removed
Resolution: duplicate
Status: newclosed

See #6634.

Note: See TracTickets for help on using tickets.