Opened 2 years ago

Closed 2 years ago

#8018 closed defect (invalid)

RPi 4 h264_mmal error

Reported by: RAJensen Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: h264_mmal
Cc: adam.bambuch2@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
h264_mmal is no longer working on RPi4 with the new Broadcom chip 64-bit BCM2711 quad-core A72 CPU @ 1.5GHz VideoCore VI GPU.
With same file, same compile it works on RPi3.
GPU Ram set to 256Gb.
How to reproduce:

sudo ffmpeg -y -v 9 -loglevel 99 -report -ss 00:00:00 -c:v h264_mmal -i 'RPI4_h264_mmal.ts' -to 00:01:00 -map 0:0 -map 0:3 -c:v h264_omx -b:v 1500k -flags +global_header -c:a:0 copy 'test.mkv'

ffmpeg version N-94282-g80dacbedba Copyright (c) 2000-2019 the FFmpeg developers
  built with gcc 8 (Raspbian 8.3.0-6+rpi1)
  configuration: --arch=armel --target-os=linux --enable-gpl --enable-mmal --enable-omx --enable-omx-rpi --enable-nonfree
built on ...
RAspberry Pi 4 OS=Buster

I don't know but i think the error occurs because that the new chip has HDMI 0 and HDMI 1. I have tried with and without 4K resolution enabled on RPi4.
Testet on Buster with desktop and Buster Lite without desktop. Test done on RPi4 2Gb Ram and 4Gb RAM.
FFMPEG info:
V..... h264_omx OpenMAX IL H.264 video encoder (codec h264)

V..... h264_v4l2m2m V4L2 mem2mem H.264 encoder wrapper (codec h264)
V..... h264_vaapi H.264/AVC (VAAPI) (codec h264)
VFS..D h264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
V..... h264_v4l2m2m V4L2 mem2mem H.264 decoder wrapper (codec h264)
V..... h264_mmal h264 (mmal) (codec h264)

Attachments (1)

ffmpeg-20190713-183308.log (133.7 KB ) - added by RAJensen 2 years ago.
FFMPEG Logfile

Download all attachments as: .zip

Change History (5)

by RAJensen, 2 years ago

Attachment: ffmpeg-20190713-183308.log added

FFMPEG Logfile

comment:1 by RAJensen, 2 years ago

FFMPEG hangs after the first line of decode/encode or it will simply write
[h264_mmal @ 0x1f29980] Did not get output frame from MMAL.
Error while decoding stream #0:0: Unknown error occurred

I've uploaded the test file, as descriped in bugreport (https://trac.ffmpeg.org/) manual with VideoLAN File Uploader

comment:2 by Carl Eugen Hoyos, 2 years ago

Component: ffmpegavcodec

comment:3 by bambuch, 2 years ago

Cc: adam.bambuch2@gmail.com added

I had the same issue (gstreamer with libgstomx-rpi.so was also freezing) as you and I was able to solve it by updating rpi firmwares (just run rpi-update command). It seems to not be the ffmpeg issue.

root@raspberrypi:/boot# cat /boot/.firmware_revision 
3c64efd8ea3366523d2ef209e0088f95016c7348

comment:4 by Carl Eugen Hoyos, 2 years ago

Resolution: invalid
Status: newclosed

Thank you for the information!

Note: See TracTickets for help on using tickets.