Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#7951 closed defect (duplicate)

Decode error with skip_frame set and a specific file

Reported by: ocrosoft Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Download media file here: http://andytather.co.uk/panda/Files/Video/HDR/LG%20Chess%20HDR.mp4

.\ffplay.exe -skip_frame "bidir" -i "D:\video\LG Chess HDR.mp4"

When set "skip_frame" arg, and it's value >= noref, ffplay may display some frames incorrect, like this:
https://www.ocrosoft.com/wp-content/uploads/2019/06/2019061009451555.png.
Other player use ffmpeg (like mpv player), the permormance is worse than ffplay, after display a "grey" frame, some mosaic remained(disappear about 1 seconds).
And more, the command line print this error message: " Could not find ref with POC xxx"(xxx mis a number).

This reproduce rate is 100% for this file.
Another video "LG Cymatic Jazz HDR10.mp4" download from "http://andytather.co.uk/panda/videogallerypage.aspx" too.
But other download from above page, it's not LG's video, ffplay and mpv play it good. May LG* video has some encode error?

Change History (3)

comment:1 by ocrosoft, 2 years ago

Resolution: duplicate
Status: newclosed

comment:2 by Balling, 2 years ago

What is this a duplicate of? I have this problem with ffplay, VLC and MPC with video encoded with nvenc (with -bf 0). But the file plays good in Potplayer and microsoft "Movies & tv".

in reply to:  2 comment:3 by Carl Eugen Hoyos, 2 years ago

Replying to Balling:

What is this a duplicate of?

Ticket #7950

Note: See TracTickets for help on using tickets.