Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7882 closed defect (invalid)

Decklink 4k Extreme output "not enough buffered video frames"

Reported by: Markus Kienast Owned by:
Priority: normal Component: avdevice
Version: unspecified Keywords: decklink
Cc: Marton Balint Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Sending video out "Decklink 4k Extreme" SDI/HDMI video card does not work properly, produces the following error repeatedly:

[decklink @ 0xf0b200] There are not enough buffered video frames. Video may misbehave!

How to reproduce:
Ubuntu 18.04,
kernel 4.15.0-48-lowlatency,
Blackmagic Desktopvideo 11.1,
FFmpeg snapshot git commit fcc01ba,
Blackmagic Decklink SDK 11.1

FFmpeg was compiled and run as a Docker image based on jrottenberg/ffmpeg ubuntu build. The modified Docker source is here: https://github.com/flaneurtv/ffmpeg

The Docker image is publicly available for testing: https://cloud.docker.com/u/flaneurtv/repository/docker/flaneurtv/ffmpeg

The tags used for testing this were:
4.1-sdk-10.11.4
snapshot-sdk-11.1

Install the respective Decklink SDK on your host system, then run:

docker run -it --device=/dev/blackmagic:/dev/blackmagic -v /srv/assets:/srv/assets -v /etc/blackmagic/BlackmagicPreferences.xml:/etc/blackmagic/BlackmagicPreferences.xml flaneurtv/ffmpeg:snapshot-sdk-11.1 -f lavfi -i testsrc2=size=3840x2160:rate=25 -f decklink -pix_fmt uyvy422 'DeckLink 4K Extreme'

The problem is the same, when using flaneurtv/ffmpeg:4.1-sdk-10.11.4 and the respective drivers on the host system.

Running ffmpeg with decklink in Docker is known to work. I am using this setup for years now, so this most certainly can be ruled out as the source of the problem.

Attachments (1)

ffmpeg-snapshot-sdk-11.1.txt (3.5 KB ) - added by Markus Kienast 4 years ago.
stdout and stderr

Download all attachments as: .zip

Change History (4)

by Markus Kienast, 4 years ago

stdout and stderr

comment:1 by Marton Balint, 4 years ago

This just usually means that yout system is too slow to be able to produce frames realtime and convert them to uyvy422. Try using -sws_flags fast_bilinear.

comment:2 by Marton Balint, 4 years ago

Resolution: invalid
Status: newclosed

comment:3 by Carl Eugen Hoyos, 4 years ago

Keywords: 4k removed
Note: See TracTickets for help on using tickets.