Opened 6 months ago

Closed 6 months ago

#7869 closed defect (duplicate)

Can't open an m4a file

Reported by: luni-4 Owned by:
Priority: important Component: avformat
Version: git-master Keywords: aac
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Hi FFmpeg developers!

I've tried to convert the m4a file attached to this issue in this way:

ffmpeg -i adts_m4a_aac_no_stream.m4a sample.mp3

ffmpeg version N-47548-g8a3ed5a313 Copyright (c) 2000-2019 the FFmpeg developers
  built with gcc 8 (Ubuntu 8.3.0-6ubuntu1~18.10)
  configuration: --disable-debug --disable-stripping --disable-libdrm --disable-cuda --enable-avisynth --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libass --enable-libbluray --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libaom --enable-libxvid --enable-shared --enable-version3
  libavutil      56. 26.100 / 56. 26.100
  libavcodec     58. 51.100 / 58. 51.100
  libavformat    58. 27.102 / 58. 27.102
  libavdevice    58.  7.100 / 58.  7.100
  libavfilter     7. 48.100 /  7. 48.100
  libswscale      5.  4.100 /  5.  4.100
  libswresample   3.  4.100 /  3.  4.100
  libpostproc    55.  4.100 / 55.  4.100
[aac @ 0x55830faeac00] Could not find codec parameters for stream 0 (Audio: aac, 0 channels, fltp): unspecified sample rate
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, aac, from 'adts_m4a_aac_no_stream.m4a':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Audio: aac, 0 channels, fltp
Output #0, mp3, to 'sample.mp3':
Output file #0 does not contain any stream

I've increased the value of analyzeduration and probesize, but nothing has changed.

The file can be opened and reproduced using VLC, so it isn't corrupted.

Thanks in advance for the reply!

Attachments (1)

adts_m4a_aac_no_stream.m4a (2.0 MB) - added by luni-4 6 months ago.
An m4a file with the ADTS format an AAC codec inside

Download all attachments as: .zip

Change History (4)

Changed 6 months ago by luni-4

An m4a file with the ADTS format an AAC codec inside

comment:1 Changed 6 months ago by jamrial

  • Analyzed by developer set
  • Component changed from ffmpeg to avformat
  • Keywords adts m4a removed
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

Looks like a regression since e023334661e6eafcf638ffc2a780fd495fc25ec9

The file is not an m4a, it's a raw adts aac file, but libavformat figured that on its own just fine.

comment:2 Changed 6 months ago by luni-4

Oh, great. Out of curiosity, why the phone has saved that as a m4a file format?

comment:3 Changed 6 months ago by cehoyos

  • Resolution set to duplicate
  • Status changed from open to closed

I believe this is a duplicate of ticket #7271.

Note: See TracTickets for help on using tickets.