Opened 7 months ago

Closed 7 months ago

#7867 closed defect (fixed)

DecklinkAPI 11.1 - Build error with media-autobuild_suite

Reported by: BlackScreen Owned by: cus
Priority: normal Component: avdevice
Version: git-master Keywords: decklink
Cc: cus Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

After the update of the DeckLink? headers to 11.1 the building process errored out with the following:

Likely error:
D:/AB-Suite/local64/include/DeckLinkAPI.h:5841:39: note:   no known conversion for argument 4 from '_BMDVideoOutputFlags' to 'BMDSupportedVideoModeFlags' {aka '_BMDSupportedVideoModeFlags'}
D:/AB-Suite/build/ffmpeg-git/libavdevice/decklink_common.cpp:287:69: error: no matching function for call to 'IDeckLinkOutput::DoesSupportVideoMode(_BMDVideoConnection, BMDDisplayMode&, BMDPixelFormat&, _BMDVideoOutputFlags, BMDDisplayMode*, BOOL*)'
                                                &actualMode, &support) != S_OK || !support || ctx->bmd_mode != actualMode) {
                                                                     ^
In file included from D:/AB-Suite/build/ffmpeg-git/libavdevice/decklink_common.cpp:28:
D:/AB-Suite/local64/include/DeckLinkAPI.h:5841:39: note: candidate: 'virtual HRESULT IDeckLinkOutput::DoesSupportVideoMode(BMDVideoConnection, BMDDisplayMode, BMDPixelFormat, BMDSupportedVideoModeFlags, BMDDisplayMode*, BOOL*)'
     virtual HRESULT STDMETHODCALLTYPE DoesSupportVideoMode(
                                       ^~~~~~~~~~~~~~~~~~~~
D:/AB-Suite/local64/include/DeckLinkAPI.h:5841:39: note:   no known conversion for argument 4 from '_BMDVideoOutputFlags' to 'BMDSupportedVideoModeFlags' {aka '_BMDSupportedVideoModeFlags'}
make: *** [/build/ffmpeg-git/ffbuild/common.mak:63: libavdevice/decklink_common.o] Error 1

More info can be found in the logs: [logs.zip] (https://0x0.st/zbPq.zip) - I have attached the logs.zip here also.
See the discussion on GitHub? here: https://github.com/jb-alvarado/media-autobuild_suite/issues/1177

Attachments (2)

logs.zip (158.6 KB) - added by BlackScreen 7 months ago.
0001-avdevice-decklink-fix-checking-video-mode-in-SDK-ver.patch (3.4 KB) - added by cus 7 months ago.

Download all attachments as: .zip

Change History (5)

Changed 7 months ago by BlackScreen

comment:1 Changed 7 months ago by cus

  • Cc cus added
  • Owner set to cus
  • Status changed from new to open

Can you try the attached patch?

comment:2 Changed 7 months ago by laurfb

Hi.
Works for me with this patch.
Regards,
Laur

comment:3 Changed 7 months ago by cehoyos

  • Component changed from undetermined to avdevice
  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.