Opened 3 years ago

Closed 16 months ago

#7791 closed defect (fixed)

Unprefixed defines

Reported by: Gramner Owned by:
Priority: normal Component: avutil
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The assembly support macros defined in the libavutil/mem.h public header does not have any prefixes which may cause namespace collisions when included by users.

They should either have some appropriate prefix added, or alternatively moved to some internal header since having them public seems to be of questionable usefulness.

This may apply to more defines in other headers as well which perhaps might be worth investigating, but DECLARE_ALIGNED happens to actually cause a name collision when libavformat/avformat.h is included by x264.

Change History (1)

comment:1 by mkver, 16 months ago

Resolution: fixed
Status: newclosed

Said macros have been deprecated in e15371061d23457554d241a80dc471515ac13ad4 and will be removed in the next+1 major version (i.e. libavutil version 58). So I am closing this despite said macros still being there, as one of your proposed solutions has been implemented (or at least scheduled).

Note: See TracTickets for help on using tickets.