Opened 5 months ago

Closed 5 months ago

#7725 closed defect (needs_more_info)

[FFmpeg-qsv][vc1 decode] vc1 decoding hangs with undefined error

Reported by: andreyor Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: qsv
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

How to reproduce:

build/lin_x64/bin/ffmpeg -y -hwaccel qsv -c:v vc1_qsv -i SA30037.vc1 -frames 900 -async_depth 1 -f null -

ffmpeg version N-92833-gfccba32b4c

Output:

[vc1_qsv @ 0x555985b5dbc0] Error during QSV decoding.: undefined behavior (-16)
Error while decoding stream #0:0: Internal bug, should not have happened
[vc1_qsv @ 0x555985b5dbc0] Error during QSV decoding.: undefined behavior (-16)
Error while decoding stream #0:0: Internal bug, should not have happened
[vc1_qsv @ 0x555985b5dbc0] Error during QSV decoding.: undefined behavior (-16)
Error while decoding stream #0:0: Internal bug, should not have happened
[vc1_qsv @ 0x555985b5dbc0] Error during QSV decoding.: undefined behavior (-16)
Error while decoding stream #0:0: Internal bug, should not have happened

Change History (5)

comment:1 Changed 5 months ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords qsv added; ffmpeg-qsv removed
  • Priority changed from important to normal

Please provide the missing information to make this a valid ticket and an input sample.

comment:2 Changed 5 months ago by fulinjie

Please provide an input sample.

comment:3 Changed 5 months ago by andreyor

Cannot reproduce with streams from http://fate-suite.ffmpeg.org/vc1/.
Only with conformance stream SA30037.vc1 (sha1sum: c6483f2e5f1de357c2f5d7ee55cebb3f5c4678f0).

Did we step into range mapping when VC1 decoder takes surfaces and don't give them back as an output, i.e. releases them silently at some point?

Last edited 5 months ago by andreyor (previous) (diff)

comment:5 Changed 5 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if you can provide the input sample.

Note: See TracTickets for help on using tickets.