Opened 5 years ago

Closed 5 years ago

#761 closed defect (duplicate)

zzufed .avi file crashes ffmpeg_g

Reported by: dianamuscalu Owned by:
Priority: important Component: avcodec
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

(gdb) bt
#0 0x000000000095bbc3 in read_sbr_grid (gb=0x7fffffffbdf0, ch_data=0x14ba290,

ac=<optimized out>, sbr=<optimized out>) at libavcodec/aacsbr.c:629

#1 0x000000000095ca37 in read_sbr_channel_pair_element (gb=0x7fffffffbdf0,

sbr=0x14ba230, ac=0x13c06e0) at libavcodec/aacsbr.c:971

#2 read_sbr_data (id_aac=1, gb=0x7fffffffbdf0, sbr=0x14ba230, ac=0x13c06e0)

at libavcodec/aacsbr.c:1003

#3 ff_decode_sbr_extension (ac=0x13c06e0, sbr=0x14ba230,

gb_host=<optimized out>, crc=<optimized out>, cnt=17, id_aac=1)
at libavcodec/aacsbr.c:1086

#4 0x0000000000956b48 in decode_extension_payload (elem_type=TYPE_CPE,

che=0x149fba0, cnt=17, gb=0x7fffffffc080, ac=0x13c06e0)
at libavcodec/aacdec.c:1729

#5 aac_decode_frame_int (avctx=0x13a2880, data=0x13a2ee0,

got_frame_ptr=0x7fffffffc348, gb=<optimized out>)
at libavcodec/aacdec.c:2225

#6 0x000000000095821e in latm_decode_frame (avctx=0x13a2880, out=0x13a2ee0,

got_frame_ptr=0x7fffffffc348, avpkt=0x7fffffffc220)
at libavcodec/aacdec.c:2569

#7 0x00000000008799ee in avcodec_decode_audio4 (avctx=0x13a2880,

frame=0x13a2ee0, got_frame_ptr=0x7fffffffc348, avpkt=0x7fffffffc220)
at libavcodec/utils.c:1056

#8 0x0000000000439fb9 in transcode_audio (got_output=0x7fffffffc348,

pkt=0x7fffffffc220, ist=0x13d28b0) at ffmpeg.c:1749

---Type <return> to continue, or q <return> to quit---
#9 output_packet (ist=<optimized out>, ost_table=0x13bfc40,

nb_ostreams=<optimized out>, pkt=<optimized out>) at ffmpeg.c:2036

#10 0x000000000043e151 in transcode (output_files=0x13e0d80,

nb_output_files=1, input_files=0x1459d70, nb_input_files=0)
at ffmpeg.c:2797

#11 0x0000000000435ba9 in main (argc=<optimized out>, argv=0x7fffffffe678)

at ffmpeg.c:4859

(gdb)

Attachments (4)

corruptfile (2.1 MB) - added by dianamuscalu 5 years ago.
use this file in ffmpeg to reproduce the crash (-i corruptfile -f null - )
bt.txt (1.7 KB) - added by dianamuscalu 5 years ago.
bt report
gdb.txt (6.8 KB) - added by dianamuscalu 5 years ago.
gdb report
valgrind.txt (9.2 KB) - added by dianamuscalu 5 years ago.
valgrind report

Change History (5)

Changed 5 years ago by dianamuscalu

use this file in ffmpeg to reproduce the crash (-i corruptfile -f null - )

Changed 5 years ago by dianamuscalu

bt report

Changed 5 years ago by dianamuscalu

gdb report

Changed 5 years ago by dianamuscalu

valgrind report

comment:1 Changed 5 years ago by michael

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of Ticket760

Note: See TracTickets for help on using tickets.