Opened 5 years ago

Closed 5 years ago

#740 closed defect (fixed)

bmp: support 32bpp x8 r8 g8 b8

Reported by: ami_stuff Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: bmp
Cc: Blocked By: 869
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

X8 R8 G8 B8—32 bits per pixel: 8 bits each for the RGB channels; 8 bits unused; no alpha.

http://www.kxcad.net/autodesk/3ds_max/Autodesk_3ds_Max_9_Reference/dds_files.html

C:\>ffmpeg -i 32bpp_x8_r8_g8_b8.bmp
ffmpeg version N-35709-g7d531e8, Copyright (c) 2000-2011 the FFmpeg developers
  built on Dec 12 2011 13:50:00 with gcc 4.6.2
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-ru
ntime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libope
ncore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --en
able-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger -
-enable-libspeex --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwben
c --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-
libxvid --enable-zlib
  libavutil    51. 32. 0 / 51. 32. 0
  libavcodec   53. 43. 0 / 53. 43. 0
  libavformat  53. 24. 0 / 53. 24. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 53. 0 /  2. 53. 0
  libswscale    2.  1. 0 /  2.  1. 0
  libpostproc  51.  2. 0 / 51.  2. 0
Input #0, image2, from '32bpp_x8_r8_g8_b8.bmp':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: bmp, bgra, 1024x768, 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

Attachments (2)

32bpp_x8_r8_g8_b8.rar (799.0 KB) - added by ami_stuff 5 years ago.
patchticket740hack.diff (766 bytes) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by ami_stuff

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords bmp added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Attached hack allows to see the intended output.

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Paul B Mahol.

comment:3 Changed 5 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

The file is read as transparent (but probably should be interpreted opaque).

comment:4 Changed 5 years ago by cehoyos

  • Blocked By set to 869
  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed by Paul B Mahol, needs #869 fixed to work for all possible conversions.

Note: See TracTickets for help on using tickets.