#7393 closed defect (fixed)

FeatureRequest: unify strftime/use_strftime

Reported by: jesusch Owned by:
Priority: minor Component: avformat
Version: git-master Keywords: hls, segment
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

Currently hls and segment demuxer have the same functionality with different parameter names

hls: -use_localtime bool
segment: -strftime bool

basically both do the same, so I think they should be named both in the same way?

Additionally there is a parameter called which only exists for hls demuxer

-use_localtime_mkdir bool

Would be nice to have the same functionallity for segment demuxer as well (and again using the same syntax

I'd vote for both muxers using the short_name (-strftime[_mkdir])

Unfortunatelly I have no clue about C but also in terms of codebase they could use the same code fragments?

Change History (3)

comment:1 Changed 21 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Priority changed from normal to minor
  • Type changed from enhancement to defect
  • Version changed from unspecified to git-master

comment:2 Changed 21 months ago by stevenliu

comment:3 Changed 21 months ago by cehoyos

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.