Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#7315 closed defect (invalid)

Audio Tempo demo range inaccurate

Reported by: MattMcManis Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

On the Wiki, atempo Filter states:

https://ffmpeg.org/ffmpeg-filters.html#atempo

To speed up audio to 300% tempo: atempo=3

Though available Range is only 0.5 - 2.

Error initializing filter 'atempo' with args '3'

Only daisy-chaining works for above 200%:

-af "atempo=sqrt(3),atempo=sqrt(3)"

Change History (3)

comment:1 follow-up: Changed 5 months ago by cehoyos

  • Component changed from wiki to undetermined
  • Keywords tempo afilter filter audio removed
  • Resolution set to invalid
  • Status changed from new to closed

Please test current FFmpeg git head before reporting issues here.

comment:2 Changed 5 months ago by Gyan

I think it's time ffmpeg.org hosted docs for each minor release in addition to master branch with a prominent notice on top of each page that indicates version being referenced and links to docs for other versions.

Since docs in release branches don't get updated all that often, regeneration interval can be weekly if not longer.

comment:3 in reply to: ↑ 1 Changed 5 months ago by llogan

Just to clarify: your ffmpeg is too old. The atempo filter has recently been updated to a max value of 100. The online documentation (which is separate from the wiki) is synced to the git master branch. If you must use an old version of ffmpeg then please refer to your local documentation, such as man ffmpeg-filters or ffmpeg -h filter=atempo.

Note: See TracTickets for help on using tickets.