Opened 4 months ago

Closed 3 months ago

#7005 closed defect (fixed)

MPEG-4 regression

Reported by: joelh1967 Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: asp regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

Attached is an MPEG-4 AVI file which reads correctly up to ffmpeg 3.3.1 but fails afterwards.

ffplay shows the following errors and the video appears scrambled.

C:\Users\harhellierj\Documents\FROMWEB\ffmpeg\ffmpeg-3.3.2-win32-static\bin>ffplay mpeg-4.avi
ffplay version 3.3.2 Copyright (c) 2003-2017 the FFmpeg developers
  built with gcc 7.1.0 (GCC)
  configuration: --enable-gpl --enable-version3 --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-libmfx --enable-nvenc --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-zlib
  libavutil      55. 58.100 / 55. 58.100
  libavcodec     57. 89.100 / 57. 89.100
  libavformat    57. 71.100 / 57. 71.100
  libavdevice    57.  6.100 / 57.  6.100
  libavfilter     6. 82.100 /  6. 82.100
  libswscale      4.  6.100 /  4.  6.100
  libswresample   2.  7.100 /  2.  7.100
  libpostproc    54.  5.100 / 54.  5.100
[mpeg4 @ 0888aaa0] Multiple VOL headersMultiple VOL headersMultiple VOL headersheader damaged
[mpeg4 @ 0888aaa0] Multiple VOL headersInput #0, avi, from 'mpeg-4.avi':
  Duration: 00:00:03.08, start: 0.000000, bitrate: 2415 kb/s
    Stream #0:0: Video: mpeg4 (Simple Profile) (XVID / 0x44495658), yuv420p, 640x480 [SAR 10:11 DAR 40:33], 2431 kb/s, 25 fps, 25 tbr, 25 tbn, 25 tbc
[mpeg4 @ 0887e2c0] Multiple VOL headersMultiple VOL headersMultiple VOL headersheader damaged
[NULL @ 0888aaa0] Context scratch buffers could not be allocated due to unknown size.
Multiple VOL headers[mpeg4 @ 0887e900] Multiple VOL headersMultiple VOL headerswarning: first frame is no keyframe
[mpeg4 @ 088929c0] Multiple VOL headersheader damaged    0B f=0/0
[mpeg4 @ 088906a0] Multiple VOL headersheader damaged    0B f=0/0   =    0KB vq=  308KB sq=    0B f=0/0
[mpeg4 @ 0887ef40] Multiple VOL headersheader damaged    0B f=0/0   =    0KB vq=  308KB sq=    0B f=0/0
[mpeg4 @ 0887e900] Multiple VOL headersheader damaged    0B f=0/0   =    0KB vq=  312KB sq=    0B f=0/0
[mpeg4 @ 0887e2c0] Multiple VOL headersheader damaged    0B f=0/0   =    0KB vq=  310KB sq=    0B f=0/0
[mpeg4 @ 088929c0] Multiple VOL headersheader damaged    0B f=0/0   =    0KB vq=  309KB sq=    0B f=0/0
[mpeg4 @ 088906a0] Multiple VOL headersheader damaged    0B f=0/0
[mpeg4 @ 0887ef40] Multiple VOL headersheader damaged    0B f=0/0
   5.05 M-V: -0.040 fd=   3 aq=    0KB vq=    0KB sq=    0B f=0/0

Attachments (1)

mpeg-4.avi (908.0 KB) - added by joelh1967 4 months ago.
MPEG-4 avi file

Download all attachments as: .zip

Change History (4)

Changed 4 months ago by joelh1967

MPEG-4 avi file

comment:1 Changed 4 months ago by joelh1967

  • Version changed from unspecified to git-master

comment:2 Changed 4 months ago by cehoyos

  • Component changed from undetermined to avcodec
  • Description modified (diff)
  • Keywords asp regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

For future tickets: Please remember to always test current FFmpeg git head when reporting bugs here (or asking questions on the user mailing list) and please do not report issues against ffplay if they are reproducible with ffmpeg.

Regression since efeb47fd5d5cbf980e52a6d5e741c3c74b94b5e2

comment:3 Changed 3 months ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Michael in 63a4bdbf3b732504e54cc2b9ec0886e6242a90bc, thank you for the report!

Note: See TracTickets for help on using tickets.