Opened 4 years ago

Closed 4 years ago

#6930 closed defect (needs_more_info)

a bug with bug with --enable-libvorbis only with latest version

Reported by: Abdalla Ibrahim Owned by:
Priority: important Component: build system
Version: git-master Keywords: libvorbis regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello,
i run centos 7
your latest version it has a bug i have cloned it from github and i have run this code

  PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="/usr/local/bin" --enable-gpl --enable-nonfree --enable-libmp3lame --enable-libvorbis --enable-libvpx --enable-libtheora --enable-libfontconfig --enable-libfreetype --enable-libfribidi

i got this error

ERROR: vorbis not found using pkg-config

after sometime i tried to install an older version of the ffmpeg
https://github.com/FFmpeg/FFmpeg/releases/tag/n3.1.8
it worked fine with no error so i figure it out that your last release has a bug with --enable-libvorbis
best regards
Abdul

Change History (7)

comment:1 by RiCON, 4 years ago

You're using a libvorbis from before 2003, congrats.

comment:2 by James, 4 years ago

Attach the config.log file generated by configure here, please.

in reply to:  2 comment:3 by Abdalla Ibrahim, 4 years ago

Replying to jamrial:

Attach the config.log file generated by configure here, please.

where can i find it i searched the system for it i could,'t find it

comment:4 by James, 4 years ago

Inside the ffbuild folder wherever you're trying to compile ffmpeg.

comment:5 by Carl Eugen Hoyos, 4 years ago

Component: undeterminedbuild system
Keywords: libvorbis regression added
Priority: normalimportant

comment:6 by Hendrik, 4 years ago

If you can reproduce this issue, please attach the missing information, otherwise this issue is invalid.

comment:7 by Carl Eugen Hoyos, 4 years ago

Resolution: needs_more_info
Status: newclosed
Note: See TracTickets for help on using tickets.