Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#6916 closed enhancement (invalid)

DVBSUB ==> DVDSUB width oversized

Reported by: Sami32 Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: dvdsub
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When converting DVBSUB to DVDSUB, the bitmap subtitle size is modified and become a slighly bigger size after been converted to DVDSUB. See the following images:
https://ibb.co/btyDh6 (DVBSUB original)
https://ibb.co/mxcnaR (DVDSUB convertion)

Sample used can be found here:
http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket2838/BDAV%20recorded%20video%20sample.ts

How to reproduce:

% ffmpeg -canvas_size 720x576 -fix_sub_duration -i "F:\!MEDIA_TEST_FILES\UMS Video Testing Suite (20150121)\TESTS\INTERNAL SUBTITLES\BDAV recorded video sample.ts" -c:v copy -c:a copy -c:s dvdsub -f matroska dvdsub.mkv

Attachments (2)

ffmpeg-20171216-170304.log (48.0 KB) - added by Sami32 7 months ago.
@6916
BDAV recorded video sample.ts_20171216_002526.359.jpg (267.5 KB) - added by Sami32 7 months ago.
#6916

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 months ago by Sami32

  • Keywords size width added; canvas removed

comment:2 Changed 7 months ago by Sami32

  • Summary changed from DVBSUB ==> DVDSUB width oversized (canvas_size issue ?) to DVBSUB ==> DVDSUB width oversized

comment:3 Changed 7 months ago by cehoyos

  • Keywords dvdsub added; DVDSUB size width removed

To make this a valid ticket, please provide the command line you tested together with the complete, uncut console output and please explain what issue you see with the output file.

Changed 7 months ago by Sami32

@6916

comment:4 follow-up: Changed 7 months ago by Sami32

My bad, i didn't thought that my log will be of any use in that case, as easily reproducible and also because i didn't saw anything, but i attached it now.

Command line and stretching explaination, and even better than my weak english, photos are also already provided.

Last edited 7 months ago by Sami32 (previous) (diff)

comment:5 in reply to: ↑ 4 Changed 7 months ago by cehoyos

Replying to Sami32:

photos are also already provided.

Why didn't you attach them?

I tested the following:

$ ffmpeg -canvas_size 720x576 -fix_sub_duration -i BDAV\ recorded\ video\ sample.ts -acodec copy -vcodec copy -scodec dvdsub out.mkv
$ ffmpeg -i BDAV\ recorded\ video\ sample.ts -filter_complex color=s=hd1080[c],[0:s]scale=hd1080,[c]overlay -ss 2 -vframes 1 out1.jpg
$ ffmpeg -i out.mkv -filter_complex color=s=hd1080[c],[0:s]scale=hd1080,[c]overlay -ss 2 -vframes 1 out2.jpg

Both subtitles look very similar here.

comment:6 follow-up: Changed 7 months ago by Sami32

Because i find it more straith forward to click on the given links and compare the media player captures from my web browser. Matter of taste i guess...

Thanks for the tips ;)

The stretched DVDSUB result, see the media player captures linked above, in the media players tested (MPC and PotPlayer?) seem to be not related to FFmpeg then, but only from the way the media players display it ?

Thank you for sharing your insight +1

Last edited 7 months ago by Sami32 (previous) (diff)

comment:7 Changed 7 months ago by Sami32

  • Resolution set to invalid
  • Status changed from new to closed

comment:8 in reply to: ↑ 6 Changed 7 months ago by cehoyos

Replying to Sami32:

Because i find it more straith forward to click on the given links and compare the media player captures from my web browser.

Which is exactly what happens if you attach the images here.

comment:9 Changed 7 months ago by Sami32

I just tried. Correct, but not good for me as the display is so big that i cannot even see the subtitle without using the mouse to deplace the image display.
I guess that should be good for people having a high definition screen display. I'm using a tiny 14" 1024x768 so that this way is not adapted to my use case.

But if you prefer pictures in attachement, i could post them as attachment as well for the next issue report.

Note: See TracTickets for help on using tickets.