Opened 5 years ago

Closed 4 years ago

#688 closed defect (duplicate)

could not find codec parameters for flv file

Reported by: xire Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: flv aac
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

ffmpeg.exe fails to recognize flv file. It plays correctly on some other players. flv file attached.

C:\files\input>X:\msys\local\bin\ffmpeg.exe -i 598316_0800_5_E_11-22-11_09-00-00_.flv
ffmpeg version 0.8.7.git, Copyright (c) 2000-2011 the FFmpeg developers

built on Nov 26 2011 15:51:16 with gcc 4.5.0
configuration: --enable-memalign-hack --extra-cflags=-I/local/include --extra-ldflags=-L/local/lib --extra-cflags=-USTRICT_ANSI --disable-pthreads
libavutil 51. 29. 1 / 51. 29. 1
libavcodec 53. 37. 1 / 53. 37. 1
libavformat 53. 21. 0 / 53. 21. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 50. 0 / 2. 50. 0
libswscale 2. 1. 0 / 2. 1. 0

[aac @ 00399160] channel element 0.0 is not allocated

Last message repeated 6461 times

[flv @ 00398a60] Could not find codec parameters (Audio: aac, 24000 Hz, stereo, s16)
598316_0800_5_E_11-22-11_09-00-00_.flv: could not find codec parameters

Attachments (1)

598316_0800_5_E_11-22-11_09-00-00_.flv (1.1 MB) - added by xire 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by xire

comment:1 Changed 5 years ago by cehoyos

  • Keywords aac added
  • Reproduced by developer set
  • Status changed from new to open
$ ffmpeg -i 598316_0800_5_E_11-22-11_09-00-00_.flv
ffmpeg version N-35182-g8f37c8f, Copyright (c) 2000-2011 the FFmpeg developers
  built on Nov 26 2011 13:50:32 with gcc 4.5.3
  configuration: --cc=/usr/local/gcc-4.5.3/bin/gcc
  libavutil    51. 29. 1 / 51. 29. 1
  libavcodec   53. 37. 1 / 53. 37. 1
  libavformat  53. 21. 0 / 53. 21. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 50. 0 /  2. 50. 0
  libswscale    2.  1. 0 /  2.  1. 0
[aac @ 0x13a3bc0] channel element 0.0 is not allocated
    Last message repeated 6461 times
[flv @ 0x139d7a0] Could not find codec parameters (Audio: aac, 24000 Hz, stereo, s16)
598316_0800_5_E_11-22-11_09-00-00_.flv: could not find codec parameters

comment:2 Changed 4 years ago by reimar

  • Resolution set to duplicate
  • Status changed from open to closed

This is a duplicate of ticket #513, the patch there works. However the file is clearly broken and I don't see a way to work around it that isn't very messy.

Last edited 4 years ago by cehoyos (previous) (diff)
Note: See TracTickets for help on using tickets.