Opened 5 years ago

Closed 5 years ago

#684 closed defect (fixed)

WebM not streamable from ffserver

Reported by: lissyx Owned by: baptiste
Priority: normal Component: ffserver
Version: git-master Keywords: webm, stream
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Streaming WebM fails. Feeding with ffmpeg works, status page shows data being transfered, and feed's file is filled correctly.

However, when requesting the stream, nothing comes out expect the 431 bytes of header.

On the ffserver side, log shows:

Wed Nov 23 12:38:43 2011 127.0.0.1 - - New connection: GET /webcam.webm
Wed Nov 23 12:38:43 2011 [ffm @ 0x2bd5780]Format ffm probed with size=2048 and score=101
Wed Nov 23 12:38:43 2011 Writing block at offset 15, size 37343, pts 0, dts 0, duration 42, flags 128
Wed Nov 23 12:38:43 2011 Writing block at offset 37381, size 1134, pts 42, dts 42, duration 42, flags 0
Wed Nov 23 12:38:43 2011 Writing block at offset 38537, size 218, pts 83, dts 83, duration 42, flags 0
Wed Nov 23 12:38:43 2011 Writing block at offset 38777, size 1101, pts 125, dts 125, duration 42, flags 0
Wed Nov 23 12:38:43 2011 Writing block at offset 39900, size 1330, pts 167, dts 167, duration 42, flags 0
Wed Nov 23 12:38:43 2011 Writing block at offset 41252, size 222, pts 208, dts 208, duration 42, flags 0
Wed Nov 23 12:38:43 2011 Writing block at offset 41496, size 1594, pts 250, dts 250, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 43113, size 6289, pts 292, dts 292, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 49425, size 47, pts 333, dts 333, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 49494, size 546, pts 375, dts 375, duration 42, flags 128
Wed Nov 23 12:38:44 2011 Writing block at offset 50063, size 47, pts 417, dts 417, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50132, size 47, pts 458, dts 458, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50201, size 47, pts 500, dts 500, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50270, size 47, pts 542, dts 542, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50339, size 47, pts 583, dts 583, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50408, size 47, pts 625, dts 625, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50477, size 48, pts 667, dts 667, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50547, size 47, pts 708, dts 708, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50616, size 48, pts 750, dts 750, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50686, size 60, pts 792, dts 792, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50768, size 48, pts 833, dts 833, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 50838, size 552, pts 875, dts 875, duration 42, flags 128
Wed Nov 23 12:38:44 2011 Writing block at offset 51413, size 53, pts 917, dts 917, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51488, size 54, pts 958, dts 958, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51564, size 64, pts 1000, dts 1000, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51650, size 48, pts 1042, dts 1042, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51720, size 66, pts 1083, dts 1083, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51808, size 91, pts 1125, dts 1125, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51921, size 53, pts 1167, dts 1167, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 51996, size 94, pts 1208, dts 1208, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 52112, size 50, pts 1250, dts 1250, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 52184, size 105, pts 1292, dts 1292, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 52311, size 106, pts 1333, dts 1333, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 52439, size 597, pts 1375, dts 1375, duration 42, flags 128
Wed Nov 23 12:38:44 2011 Writing block at offset 53059, size 236, pts 1417, dts 1417, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 53318, size 76, pts 1458, dts 1458, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 53416, size 445, pts 1500, dts 1500, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 53884, size 903, pts 1542, dts 1542, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 54810, size 200, pts 1583, dts 1583, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 55033, size 1169, pts 1625, dts 1625, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 56225, size 279, pts 1667, dts 1667, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 56527, size 1988, pts 1708, dts 1708, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 58538, size 2690, pts 1750, dts 1750, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 61251, size 527, pts 1792, dts 1792, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 61801, size 2334, pts 1833, dts 1833, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 64158, size 2756, pts 1875, dts 1875, duration 42, flags 128
Wed Nov 23 12:38:44 2011 Writing block at offset 66937, size 3809, pts 1917, dts 1917, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 70769, size 747, pts 1958, dts 1958, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 71539, size 4935, pts 2000, dts 2000, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 76497, size 6181, pts 2042, dts 2042, duration 42, flags 0
Wed Nov 23 12:38:44 2011 Writing block at offset 82701, size 1163, pts 2083, dts 2083, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 83887, size 7185, pts 2125, dts 2125, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 91095, size 4679, pts 2167, dts 2167, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 95797, size 3792, pts 2208, dts 2208, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 99612, size 8815, pts 2250, dts 2250, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 108450, size 1076, pts 2292, dts 2292, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 109549, size 9733, pts 2333, dts 2333, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 119305, size 10503, pts 2375, dts 2375, duration 42, flags 128
Wed Nov 23 12:38:45 2011 Writing block at offset 129831, size 6661, pts 2417, dts 2417, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 136515, size 6059, pts 2458, dts 2458, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 142597, size 566, pts 2500, dts 2500, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 143186, size 6575, pts 2542, dts 2542, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 149784, size 5020, pts 2583, dts 2583, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 154827, size 834, pts 2625, dts 2625, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 155684, size 5400, pts 2667, dts 2667, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 161107, size 6003, pts 2708, dts 2708, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 167133, size 4613, pts 2750, dts 2750, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 171769, size 666, pts 2792, dts 2792, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 172458, size 5684, pts 2833, dts 2833, duration 42, flags 0
Wed Nov 23 12:38:45 2011 Writing block at offset 178165, size 12637, pts 2875, dts 2875, duration 42, flags 128
Wed Nov 23 12:38:45 2011 Writing block at offset 190825, size 148, pts 2917, dts 2917, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 190996, size 7013, pts 2958, dts 2958, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 198032, size 411, pts 3000, dts 3000, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 198466, size 7169, pts 3042, dts 3042, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 205658, size 267, pts 3083, dts 3083, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 205948, size 5659, pts 3125, dts 3125, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 211630, size 4249, pts 3167, dts 3167, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 215902, size 781, pts 3208, dts 3208, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 216706, size 6085, pts 3250, dts 3250, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 222814, size 3740, pts 3292, dts 3292, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 226577, size 471, pts 3333, dts 3333, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 227071, size 14470, pts 3375, dts 3375, duration 42, flags 128
Wed Nov 23 12:38:46 2011 Writing block at offset 241564, size 3876, pts 3417, dts 3417, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 245463, size 2854, pts 3458, dts 3458, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 248340, size 484, pts 3500, dts 3500, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 248847, size 4046, pts 3542, dts 3542, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 252916, size 3298, pts 3583, dts 3583, duration 42, flags 0
Wed Nov 23 12:38:46 2011 Writing block at offset 256237, size 270, pts 3625, dts 3625, duration 42, flags 0

On the "client" side, simulated with wget:

$ LC_ALL=C wget -O test "http://127.0.0.1:8001/webcam.webm" 
--2011-11-23 12:38:43--  http://127.0.0.1:8001/webcam.webm
Connecting to 127.0.0.1:8001... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [video/webm]
Saving to: `test'

    [   <=>                                                                             ] 431         --.-K/s    

ffserver.conf is:

BindAddress 127.0.0.1
Port 8001

MaxHTTPConnections 8
MaxClients 8
MaxBandwidth 10000

<Stream status.html>
Format status
ACL allow localhost
</Stream>

<Feed webcam.ffm>
File /tmp/webcam.ffm
FileMaxSize 100k
ACL allow 127.0.0.1
</Feed>

<Stream webcam.webm>
Format webm
Feed webcam.ffm
VideoFrameRate 8
VideoCodec libvpx
VideoSize 320x240
VideoBitRate 384k
VideoQMin 1
VideoQMax 31
Preroll 0
AVOptionVideo flags +global_header
NoAudio
</Stream>

This is reproduced with at least version from:

$ git describe 
n0.8-4175-g0b9a69f
ffserver version N-35110-g0b9a69f, Copyright (c) 2000-2011 the FFmpeg developers
  built on Nov 23 2011 13:03:00 with gcc 4.6.1
  configuration: --enable-encoder=mpeg1video --enable-decoder=mjpeg --enable-postproc --enable-libpulse --enable-libvpx --enable-libtheora --enable-libvorbis --enable-ffserver
  libavutil    51. 26. 0 / 51. 26. 0
  libavcodec   53. 37. 0 / 53. 37. 0
  libavformat  53. 21. 0 / 53. 21. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 49. 0 /  2. 49. 0
  libswscale    2.  1. 0 /  2.  1. 0
Wed Nov 23 14:34:02 2011 FFserver started.

Change History (2)

comment:1 Changed 5 years ago by lissyx

Hello,

I just retried on an updated git tree: $ git describe
n0.8-10264-g64df092

and now it seems to be working :)

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Thank you for testing again!

Note: See TracTickets for help on using tickets.