Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#6759 closed enhancement (duplicate)

XDCAM MXF - how to apply patch to mxfenc.c

Reported by: AxelTechnology Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: mxf
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello everyone,
in August 2016 we modified the mxfenc.c module [N-81118-gfb91850 version] and recompiled libavformat to achieve SONY Browser compatibility with MXF files created with ffmpeg.

We provide the original and the modified mxfenc.c file with the patch. The changes are marked with // XDCAM.

Let's apply it on the current git-master!

The Axel Technology team

Attachments (3)

mxfenc.c (111.3 KB ) - added by AxelTechnology 4 years ago.
patched mxfenc.c
mxfenc_original.c (107.1 KB ) - added by AxelTechnology 4 years ago.
original mxfenc.c
0001-Sony-XDCAM-Fix.patch (22.3 KB ) - added by AxelTechnology 4 years ago.

Download all attachments as: .zip

Change History (9)

by AxelTechnology, 4 years ago

Attachment: mxfenc.c added

patched mxfenc.c

by AxelTechnology, 4 years ago

Attachment: mxfenc_original.c added

original mxfenc.c

comment:1 by gjdfgh, 4 years ago

Do you not know what patches are?

by AxelTechnology, 4 years ago

Attachment: 0001-Sony-XDCAM-Fix.patch added

comment:2 by AxelTechnology, 4 years ago

Now we do. You can find the git generated patch in the attachments

comment:3 by Carl Eugen Hoyos, 4 years ago

Please remove all comments, all tabs, all white space changes and the logging from your patch and send it to the FFmpeg development mailing list for review.

comment:4 by Carl Eugen Hoyos, 4 years ago

Keywords: xdcam patch removed
Priority: normalwish

comment:5 by Carl Eugen Hoyos, 4 years ago

Resolution: duplicate
Status: newclosed

Please reopen if this is not a duplicate of ticket #5097.

comment:6 by vimlesh1975, 3 years ago

Hi
Is this patched?

Last edited 3 years ago by vimlesh1975 (previous) (diff)
Note: See TracTickets for help on using tickets.