Opened 5 years ago

Closed 7 months ago

#664 closed enhancement (fixed)

add support for iff anim

Reported by: ami_stuff Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords: iff anim
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

IFF ANIM file format info:

http://amigan.1emu.net/reg/iff.html

IFF ANIM player with source code:

http://aminet.net/package/gfx/show/iffanimplay_68k

Sample IFF ANIM files:

http://aminet.net/pix/anim

C:\>ffmpeg -i 040.anim
ffmpeg version N-34704-g985e768, Copyright (c) 2000-2011 the FFmpeg developers
  built on Nov 11 2011 01:49:15 with gcc 4.6.2
  configuration: --disable-static --enable-shared --enable-gpl --enable-version3
 --disable-w32threads --enable-runtime-cpudetect --enable-avisynth --enable-bzli
b --enable-frei0r --enable-libopencore-amrnb --enable-libopencore-amrwb --enable
-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-l
ibrtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-li
bvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-l
ibx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil    51. 24. 1 / 51. 24. 1
  libavcodec   53. 31. 0 / 53. 31. 0
  libavformat  53. 20. 0 / 53. 20. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 47. 2 /  2. 47. 2
  libswscale    2.  1. 0 /  2.  1. 0
  libpostproc  51.  2. 0 / 51.  2. 0
040.anim: Invalid data found when processing input

Attachments (2)

040.anim (489.3 KB) - added by ami_stuff 5 years ago.
iffanimplay.exe (311.5 KB) - added by ami_stuff 5 years ago.

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by ami_stuff

comment:1 Changed 5 years ago by ami_stuff

I forgot about XAnim.

http://xanim.polter.net/

IFF Animations and Images

    * Color cycling with single images and animations.
    * Supported IFF Compressions:
          o Anim3
          o Anim5
          o Anim7
          o AnimJ
          o Animl
    * Supported Amiga Display modes:
          o normal(BitPlanes) depths 1 - 8.
          o Extra Half-Brite(EHB) depth 6
          o HAM(Hold And Modify) depth 6 and 8

comment:2 Changed 5 years ago by cehoyos

  • Keywords iff anim added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Type changed from defect to enhancement
  • Version changed from unspecified to git-master

comment:3 follow-up: Changed 5 years ago by ami_stuff

I have created some samples:

http://www.datafilehost.com/download-0ecca2be.html

I will attache win32 player since the author's site seems to be down for good.

Changed 5 years ago by ami_stuff

comment:4 Changed 18 months ago by richardpl

  • Summary changed from add suppoer for iff anim to add support for iff anim

comment:5 Changed 10 months ago by ami_stuff

too bad that this got not implemented for so many years. even virtualdub seems to support iff anims internally (well, support is buggy, but at least they tried ;) )

comment:6 follow-up: Changed 10 months ago by richardpl

There is always bounty button.

comment:7 in reply to: ↑ 6 Changed 10 months ago by ami_stuff

Replying to richardpl:

There is always bounty button.

well, one can still use some other software to decode iff anim, but it would BE NICE to have it supported in ffmpeg - maybe in the next 10 years someone will decide to implement it for free just for fun, who knows

comment:8 Changed 10 months ago by richardpl

Only one who cares - you.

comment:9 Changed 10 months ago by ami_stuff

looks like xine supports it since 2004:

http://permalink.gmane.org/gmane.comp.video.xine.announce/26

comment:11 Changed 9 months ago by ami_stuff

here are some rare samples (please upload to /ticket664 before link dies)

http://www.datafilehost.com/d/f892abb6

comment:13 Changed 7 months ago by ami_stuff

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in cb928fc448f9566e6f6c28d53fa4c2388e732a2b by Paul B Mahol

Note: See TracTickets for help on using tickets.