Opened 15 months ago

Closed 6 months ago

#6484 closed defect (worksforme)

libavfilter.a: File in wrong format

Reported by: svnpenn Owned by:
Priority: important Component: build system
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

x86_64-w64-mingw32-ar: libavfilter/libavfilter.a: File in wrong format

I did a git bisect, here is the result:

18f09524f72ccc56273859fceb2c7cf1c7b15c78 is the first bad commit
commit 18f09524f72ccc56273859fceb2c7cf1c7b15c78
Author: Rostislav Pehlivanov <atomnuker@gmail.com>
Date:   Tue May 16 12:08:37 2017 +0100

    configure: use -x instead of -wN ..@ to strip assembly files

    Reduces the amount of debugging information of external asm from
    uselessly verbose to informative enough.

    Signed-off-by: Rostislav Pehlivanov <atomnuker@gmail.com>
    Reviewed-by: James Darnley <james.darnley@gmail.com>

Change History (4)

comment:1 Changed 12 months ago by cehoyos

  • Component changed from undetermined to build system
  • Keywords regression added
  • Priority changed from normal to important
  • Version changed from unspecified to git-master

comment:2 Changed 6 months ago by richardpl

Is this still relevant?

comment:3 Changed 6 months ago by svnpenn

I just tried this again with the commit in question (and with x264 2451a72) and I cannot reproduce the original error

perhaps it was a problem with one of my build tools at the time

i would consider the issue resolved - unless someone can reproduce the error - thanks

comment:4 Changed 6 months ago by heleppkes

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.