Opened 2 years ago

Closed 2 years ago

#6462 closed defect (duplicate)

General Protection Fault in ff_vp9_iadst_iadst_16x16_add_10_sse2

Reported by: tsmith Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

valgrind -q ./ffmpeg -f ivf -i test_case.ivf -frames 5 -f null -
ffmpeg version N-86447-gfeb13ae Copyright (c) 2000-2017 the FFmpeg developers
  built with clang version 3.8.0-2ubuntu4 (tags/RELEASE_380/final)
  configuration: --cc=clang --cxx=clang++ --disable-libxcb --disable-xlib --disable-logging --disable-ffprobe --disable-ffplay --disable-sdl2 --disable-ffserver --disable-doc --disable-pthreads --disable-network --disable-d3d11va --disable-dxva2 --disable-vaapi --disable-vda --disable-vdpau --disable-stripping --disable-runtime-cpudetect --disable-postproc --disable-securetransport --disable-iconv --disable-swscale --disable-avdevice --disable-videotoolbox --disable-everything --enable-encoder=wrapped_avframe --disable-lzma --enable-protocol='file,pipe' --enable-muxer=null --enable-demuxer=ivf --enable-parser=vp9 --enable-decoder=vp9 --disable-pic
  libavutil      55. 63.100 / 55. 63.100
  libavcodec     57. 98.100 / 57. 98.100
  libavformat    57. 73.100 / 57. 73.100
  libavfilter     6. 92.100 /  6. 92.100
  libswresample   2.  8.100 /  2.  8.100


Process terminating with default action of signal 11 (SIGSEGV)
 General Protection Fault
   at 0x657C02: ff_vp9_iadst_iadst_16x16_add_10_sse2 (vp9itxfm_16bpp.asm:1577)
   by 0x4ED4DD: ff_vp9_decode_block (vp9block.c:1385)
   by 0x4EA66B: decode_sb (vp9.c:959)
   by 0x4EA4D5: decode_sb (vp9.c:984)
   by 0x4DF174: vp9_decode_frame (vp9.c:1314)
   by 0x4C0FAB: decode_simple_internal (decode.c:417)
   by 0x4C0FAB: decode_simple_receive_frame (decode.c:620)
   by 0x4C0FAB: decode_receive_frame_internal (decode.c:638)
   by 0x4C05D9: avcodec_send_packet (decode.c:678)
   by 0x439856: decode (ffmpeg.c:2246)
   by 0x439856: decode_video (ffmpeg.c:2390)
   by 0x439856: process_input_packet (ffmpeg.c:2625)
   by 0x43501A: process_input (ffmpeg.c:4409)
   by 0x43501A: transcode_step (ffmpeg.c:4520)
   by 0x43501A: transcode (ffmpeg.c:4569)
   by 0x42DFAD: main (ffmpeg.c:4748)

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (1)

test_case.ivf (28.0 KB) - added by tsmith 2 years ago.

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by tsmith

comment:1 Changed 2 years ago by rbultje

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of 6459.

Note: See TracTickets for help on using tickets.