Opened 2 years ago

Closed 2 years ago

#6460 closed defect (duplicate)

Invalid free() in vp9.c

Reported by: tsmith Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

How to reproduce:

./ffmpeg -f ivf -i test_case.ivf -frames 5 -f null -
ffmpeg version N-86447-gfeb13ae Copyright (c) 2000-2017 the FFmpeg developers
  built with clang version 3.8.0-2ubuntu4 (tags/RELEASE_380/final)
  configuration: --cc=clang --cxx=clang++ --disable-libxcb --disable-xlib --disable-logging --disable-ffprobe --disable-ffplay --disable-sdl2 --disable-ffserver --disable-doc --disable-pthreads --disable-network --disable-d3d11va --disable-dxva2 --disable-vaapi --disable-vda --disable-vdpau --disable-stripping --disable-runtime-cpudetect --disable-postproc --disable-securetransport --disable-iconv --disable-swscale --disable-avdevice --disable-videotoolbox --disable-everything --enable-encoder=wrapped_avframe --disable-lzma --enable-protocol='file,pipe' --enable-muxer=null --enable-demuxer=ivf --enable-parser=vp9 --enable-decoder=vp9 --disable-pic
  libavutil      55. 63.100 / 55. 63.100
  libavcodec     57. 98.100 / 57. 98.100
  libavformat    57. 73.100 / 57. 73.100
  libavfilter     6. 92.100 /  6. 92.100
  libswresample   2.  8.100 /  2.  8.100

Invalid free() / delete / delete[] / realloc()
   at 0x4C2EDEB: free (in /usr/lib/valgrind/vgpreload_memcheck-amd64-linux.so)
   by 0x6D5882: av_free (mem.c:209)
   by 0x6D5882: av_freep (mem.c:219)
   by 0x4DFF5E: free_buffers (vp9.c:1071)
   by 0x4DFF5E: vp9_decode_free (vp9.c:1092)
   by 0x4D5F30: avcodec_close (utils.c:1179)
   by 0x4362A5: transcode (ffmpeg.c:4634)
   by 0x42DFAD: main (ffmpeg.c:4748)
 Address 0x6dc06ef07040717 is not stack'd, malloc'd or (recently) free'd

Attachments (1)

test_case.ivf (14.3 KB) - added by tsmith 2 years ago.

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by tsmith

comment:1 Changed 2 years ago by tsmith

The stack trace was generated with Valgrind

comment:2 Changed 2 years ago by rbultje

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of 6459.

Note: See TracTickets for help on using tickets.