Opened 4 years ago

Closed 15 months ago

Last modified 15 months ago

#6348 closed enhancement (fixed)

SRT - Secure Reliable Transport Protocol

Reported by: FishB8 Owned by:
Priority: wish Component: avformat
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Haivision has had a transport protocol they've been using in their appliances that in my personal experience using it, offers a lot of advantages for point-to-point streams when compared to UDP protocols.

They announced that in collaboration with Wowza they have open-sourced the protocol. Although it probably need vetting, it looks like a very genuine effort at standardization since they have released reference code (C++) under LGPL-2.1.

https://github.com/Haivision/srt

I would hope ffmpeg could integrate it in the near future as this provides much needed functionality in the area of streaming transport protocols.

Change History (4)

comment:1 by FishB8, 4 years ago

I should add the URL for the project page:

http://www.srtalliance.org/

comment:2 by Carl Eugen Hoyos, 4 years ago

Component: undeterminedavformat
Keywords: SRT Transport removed
Priority: normalwish
Version: unspecifiedgit-master

comment:3 by barhom, 15 months ago

Resolution: fixed
Status: newclosed

This has been implemented.

Note: See TracTickets for help on using tickets.