Opened 5 years ago

Closed 5 years ago

#629 closed defect (fixed)

Using -psnr gives an "Unrecognized option" error

Reported by: dericed Owned by:
Priority: important Component: ffmpeg
Version: git-master Keywords: psnr
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

This -psnr option used to work (at least it did in a build I have from July 7, 2011's git master), but lately it gives an unrecognized option error. The -psnr option is documented here: http://ffmpeg.org/ffmpeg.html.

ffmpeg -i MPEG2_8.mov -psnr MPEG_8.avi
ffmpeg version N-30853-gf955fdc, Copyright (c) 2000-2011 the FFmpeg developers
  built on Nov  1 2011 00:17:17 with gcc 4.2.1 (Apple Inc. build 5666) (dot 3)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/HEAD --enable-shared --enable-gpl --enable-version3 --enable-nonfree --enable-hardcoded-tables --cc=/usr/bin/gcc-4.2 --enable-libx264 --enable-libfaac --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libxvid
  libavutil    51. 22. 0 / 51. 22. 0
  libavcodec   53. 26. 0 / 53. 26. 0
  libavformat  53. 18. 0 / 53. 18. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 45. 3 /  2. 45. 3
  libswscale    2.  1. 0 /  2.  1. 0
  libpostproc  51.  2. 0 / 51.  2. 0

Seems stream 0 codec frame rate differs from container frame rate: 59.94 (60000/1001) -> 29.97 (2997/100)

Seems stream 2 codec frame rate differs from container frame rate: 2997.00 (2997/1) -> 29.97 (2997/100)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'MPEG2_8.mov':
  Metadata:
    creation_time   : 2011-10-28 16:19:34
  Duration: 00:00:30.53, start: 0.367042, bitrate: 11827 kb/s
    Stream #0:0(eng): Video: mpeg2video (4:2:2) (mpeg / 0x6765706D), yuv422p, 720x480 [SAR 8:9 DAR 4:3], 8000 kb/s, 29.97 fps, 29.97 tbr, 2997 tbn, 59.94 tbc
    Metadata:
      creation_time   : 2011-10-28 16:19:49
      handler_name    : ?Apple Alias Data Handler
    Stream #0:1(eng): Audio: pcm_s24be (in24 / 0x34326E69), 48000 Hz, 2 channels, s32, 2304 kb/s
    Metadata:
      creation_time   : 2011-10-28 16:19:49
      handler_name    : ?Apple Alias Data Handler
    Stream #0:2(eng): Video: none (Ovbi / 0x6962764F), 347 kb/s, 29.97 fps, 29.97 tbr, 2997 tbn, 2997 tbc
    Metadata:
      creation_time   : 2011-10-28 16:19:49
      handler_name    : ?Apple Alias Data Handler
    Stream #0:3(eng): Data: none (tmcd / 0x64636D74)
    Metadata:
      creation_time   : 2011-10-28 16:19:49
      handler_name    : ?Apple Alias Data Handler
Unrecognized option 'psnr'
Failed to set value 'MPEG_8.avi' for option 'psnr'

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

This is a regression since 411cc5c46a89ce0a79832c37d0eab1ed884e5423.

comment:2 Changed 5 years ago by cehoyos

  • Component changed from avcodec to FFmpeg
  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed, thank you for the report!

Note: See TracTickets for help on using tickets.