Opened 2 years ago

Closed 2 months ago

#6278 closed defect (invalid)

[crash] dshow list_options of video and audio component at the same time

Reported by: Djfe Owned by:
Priority: normal Component: ffmpeg
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg crashes reproducably on Win10 64bit (education edition)
if I execute it with:
ffmpeg -list_options true -f dshow -i video="video-device-name":audio="audio-device-name"

forwarding only video or audio by themselves doesn't result in a crash, but combining them seems to do it every time
(I haven't checked every combination, but I attached logs of 2 tries; I don't know how to create traces on Windows, since the how to bug report page only seems to name Linux tools (gdb and valgrind))

apart from that the output seems to be correct though (first a list of video options, then a list of audio options)

Attachments (3)

ffmpeg-20170330-170706.log (13.2 KB) - added by Djfe 2 years ago.
ffmpeg report log; device: Magewell USB Capture HDMI (it does HDMI -> USB 3.0 -> UVC)
ffmpeg-20170330-173742.log (5.3 KB) - added by Djfe 2 years ago.
ffmpeg report log; device: https://github.com/rdp/screen-capture-recorder-to-video-windows-free as video and my soundcard's mic input as audio
cmd_2017-03-30_17-07-36.png (86.6 KB) - added by Djfe 2 years ago.
Screenshot of the console

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by Djfe

ffmpeg report log; device: Magewell USB Capture HDMI (it does HDMI -> USB 3.0 -> UVC)

Changed 2 years ago by Djfe

ffmpeg report log; device: https://github.com/rdp/screen-capture-recorder-to-video-windows-free as video and my soundcard's mic input as audio

Changed 2 years ago by Djfe

Screenshot of the console

comment:1 Changed 2 years ago by cehoyos

gdb works fine on Windows...

comment:2 Changed 2 months ago by Djfe

  • Resolution set to invalid
  • Status changed from new to closed

Can't reproduce this anymore, seems to have been fixed over time.

Note: See TracTickets for help on using tickets.