Opened 10 years ago

Closed 10 years ago

#611 closed defect (fixed)

missing G726 support for rtp and rtsp

Reported by: Miroslav Slugeň Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: g726 rtp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi, G726 formats are not supported in RTSP protocol, i created patch with G726 support for rtp and rtsp decoder. Please feel free to modify it, i don't need any copyright, my only point is to get it to ffmpeg main tree.

Attachments (4)

rtp_g726.diff (4.5 KB ) - added by Miroslav Slugeň 10 years ago.
Patch for adding support of G726 decoder to RTP and RTSP streams.
rtsp.log (3.0 KB ) - added by Miroslav Slugeň 10 years ago.
Log from stream (h264 + G726)
0001-libavformat-add-support-for-G726-audio-decoder-in-RT.patch (5.1 KB ) - added by Miroslav Slugeň 10 years ago.
Signed patch
0001-libavformat-add-G726-audio-decoder-in-RTP.patch (5.9 KB ) - added by Miroslav Slugeň 10 years ago.
Updated signed patch

Download all attachments as: .zip

Change History (11)

by Miroslav Slugeň, 10 years ago

Attachment: rtp_g726.diff added

Patch for adding support of G726 decoder to RTP and RTSP streams.

by Miroslav Slugeň, 10 years ago

Attachment: rtsp.log added

Log from stream (h264 + G726)

comment:1 by Miroslav Slugeň, 10 years ago

Camera with RTSP stream, H264 video and G726 audio is for example AirLive OD-2025HD, but there are much more such devices, they work without problems in vlc. And now they works also in ffmpeg with this patch.

comment:2 by Michael Niedermayer, 10 years ago

Please add a license header to the new file and a commit message to the patch (git format-patch -1 will create a patch out of a last local commit with commit message)

thanks

by Miroslav Slugeň, 10 years ago

Signed patch

comment:3 by Miroslav Slugeň, 10 years ago

I also send patch to ffmpeg-devel list, so we have to wait :)

comment:4 by Carl Eugen Hoyos, 10 years ago

Keywords: rtp added
Version: unspecifiedgit-master

Please copy the license header (the first 20 lines of any file in the directory libavformat) into your new file rtpdec_g726.c, change the second line into something like "RTP G.726 protocol (RFC XXX)" and put your name in the third line.

by Miroslav Slugeň, 10 years ago

Updated signed patch

comment:5 by Miroslav Slugeň, 10 years ago

Ok, i add licence header to new file, i hope that is everything :)

comment:6 by Miroslav Slugeň, 10 years ago

Patch is since now in ffmpeg git, so it should be also in version 0.8.7, thanks, this ticket can be closed.

Last edited 10 years ago by Miroslav Slugeň (previous) (diff)

comment:7 by Carl Eugen Hoyos, 10 years ago

Resolution: fixed
Status: newclosed

Per your request merged into release/0.8.

Note: See TracTickets for help on using tickets.