Opened 2 years ago

Closed 2 years ago

#6095 closed defect (invalid)

mumudvb DVB-T via LAN to ffmpeg RTMP transcode errors

Reported by: paule3d Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

PC 1: Ubuntu. DVB-T card. mumudvb. UK terrestrial TV.
PC 2: Ubuntu used for transcoding.
(1gbps LAN)

If PC 1 runs this ffmpeg command, it works OK and can view via remote NGINX server. I watched for 30 mins with no problem.

If PC 2 runs this ffmpeg command (across LAN from PC 1) first few seconds seems to be OK, then many command line errors start, and keeps looping.

ffmpeg -re -f mpegts -err_detect ignore_err -i http://192.168.1.94:4028/bysid/4222 -c:a aac -b:a 64k -strict -2 -s 512x288 -f:v "yadif=0:-1:1" -c:v libx264 -b:v 450K -bufsize 450k -profile:v baseline -level 3.0 -r 25 -g 50 -keyint_min 50 -sc_threshold 0 -x264opts "keyint=50:min-keyint=50:no-scenecut" -f flv rtmp://*.*.*.*:1936/tv -loglevel warning

[mpeg2video @ 0x1e3c440] Invalid frame dimensions 0x0.

Last message repeated 5 times

[mpegts @ 0x1e36720] Could not find codec parameters for stream 2 (Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels, s16p): unspecified frame size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0x1e36720] Could not find codec parameters for stream 5 (Unknown: none ([5][0][0][0] / 0x0005)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0x1e36720] Could not find codec parameters for stream 6 (Unknown: none ([11][0][0][0] / 0x000B)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0x1e36720] Could not find codec parameters for stream 7 (Unknown: none ([11][0][0][0] / 0x000B)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0x1e36720] Could not find codec parameters for stream 8 (Unknown: none ([5][0][0][0] / 0x0005)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[libx264 @ 0x211c980] VBV maxrate unspecified, assuming CBR
[mpegts @ 0x1e36720] PES packet size mismatch
[mp2 @ 0x1e85e00] Header missing
Error while decoding stream #0:1: Invalid data found when processing input
[mpeg2video @ 0x1eb3300] skipped MB in I frame at 14 11
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpeg2video @ 0x1eb3300] ac-tex damaged at 29 14
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpeg2video @ 0x1eb3300] ac-tex damaged at 22 4
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpeg2video @ 0x1eb3300] ac-tex damaged at 6 23
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpeg2video @ 0x1eb3300] invalid mb type in B Frame at 2 16
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpeg2video @ 0x1eb3300] 00 motion_type at 30 10
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpegts @ 0x1e36720] PES packet size mismatch
[mp2 @ 0x1e85e00] Header missing
Error while decoding stream #0:1: Invalid data found when processing input
[mpegts @ 0x1e36720] PES packet size mismatch
[mp2 @ 0x1e85e00] Header missing
Error while decoding stream #0:1: Invalid data found when processing input
[mpeg2video @ 0x1eb3300] mb incr damaged
[mpeg2video @ 0x1eb3300] 00 motion_type at 9 4
[mpeg2video @ 0x1eb3300] ac-tex damaged at 6 7
[mpeg2video @ 0x1eb3300] 00 motion_type at 5 5
[mpeg2video @ 0x1eb3300] 00 motion_type at 5 14
[mpeg2video @ 0x1eb3300] 00 motion_type at 6 29
[mpeg2video @ 0x1eb3300] ac-tex damaged at 17 30
[mpeg2video @ 0x1eb3300] 00 motion_type at 17 22
[mpeg2video @ 0x1eb3300] 00 motion_type at 2 6
[mpeg2video @ 0x1eb3300] 00 motion_type at 38 15
[mpeg2video @ 0x1eb3300] 00 motion_type at 1 16
[mpeg2video @ 0x1eb3300] 00 motion_type at 16 8
[mpeg2video @ 0x1eb3300] 00 motion_type at 6 31
[mpeg2video @ 0x1eb3300] 00 motion_type at 9 23
[mpeg2video @ 0x1eb3300] ac-tex damaged at 12 32
[mpeg2video @ 0x1eb3300] 00 motion_type at 7 20
[mpeg2video @ 0x1eb3300] 00 motion_type at 37 33
[mpeg2video @ 0x1eb3300] 00 motion_type at 6 24
[mpeg2video @ 0x1eb3300] ac-tex damaged at 6 25
[mpeg2video @ 0x1eb3300] ac-tex damaged at 14 26
[mpeg2video @ 0x1eb3300] invalid mb type in B Frame at 11 27
[mpeg2video @ 0x1eb3300] mb incr damaged
[mpeg2video @ 0x1eb3300] 00 motion_type at 4 21
[mpeg2video @ 0x1eb3300] 00 motion_type at 4 9
[mpeg2video @ 0x1eb3300] 00 motion_type at 10 10
[mpeg2video @ 0x1eb3300] 00 motion_type at 3 34
[mpeg2video @ 0x1eb3300] 00 motion_type at 11 11
[mpeg2video @ 0x1eb3300] 00 motion_type at 7 35
[mpeg2video @ 0x1eb3300] 00 motion_type at 8 12
[mpeg2video @ 0x1eb3300] 00 motion_type at 1 13
[mpeg2video @ 0x1eb3300] Warning MVs not available
[mpegts @ 0x1e36720] PES packet size mismatch
[mp2 @ 0x1e85e00] Header missing
Error while decoding stream #0:1: Invalid data found when processing input

Infinite loop of similar messages

Please help!

Change History (5)

comment:1 Changed 2 years ago by cehoyos

Please understand that -loglevel warning is not valid for bug reports, at least default loglevel is required (unless you want to report an issue with the loglevel option).

comment:2 Changed 2 years ago by paule3d

PC 1: Ubuntu. DVB-T card. mumudvb. UK terrestrial TV.
PC 2: Ubuntu used for transcoding, across 1gbps LAN.

If PC 1 runs this ffmpeg command, it works OK and can view via remote NGINX server. I watched for 30 mins with no problem.

If PC 2 runs this ffmpeg command (across LAN from PC 1) first few seconds seems to be OK, then many command line errors start, and keeps looping.

ffmpeg -re -f mpegts -err_detect ignore_err -i http://192.168.1.94:4028/bysid/4222 -c:a aac -b:a 64k -strict -2 -s 512x288 -f:v "yadif=0:-1:1" -c:v libx264 -b:v 450K -bufsize 450k -profile:v baseline -level 3.0 -r 25 -g 50 -keyint_min 50 -sc_threshold 0 -x264opts "keyint=50:min-keyint=50:no-scenecut" -f flv rtmp://*.*.*.*:1936/tv
ffmpeg version 2.8.10-0ubuntu0.16.04.1 Copyright (c) 2000-2016 the FFmpeg developers

built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.4) 20160609
configuration: --prefix=/usr --extra-version=0ubuntu0.16.04.1 --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-libopencv
libavutil 54. 31.100 / 54. 31.100
libavcodec 56. 60.100 / 56. 60.100
libavformat 56. 40.101 / 56. 40.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 40.101 / 5. 40.101
libavresample 2. 1. 0 / 2. 1. 0
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.101 / 1. 2.101
libpostproc 53. 3.100 / 53. 3.100

[mpeg2video @ 0xbc8400] Invalid frame dimensions 0x0.

Last message repeated 3 times

[mpegts @ 0xbc26e0] Could not find codec parameters for stream 2 (Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels, s16p): unspecified frame size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0xbc26e0] Could not find codec parameters for stream 5 (Unknown: none ([5][0][0][0] / 0x0005)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0xbc26e0] Could not find codec parameters for stream 6 (Unknown: none ([11][0][0][0] / 0x000B)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0xbc26e0] Could not find codec parameters for stream 7 (Unknown: none ([11][0][0][0] / 0x000B)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0xbc26e0] Could not find codec parameters for stream 8 (Unknown: none ([5][0][0][0] / 0x0005)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, mpegts, from 'http://192.168.1.94:4028/bysid/4222':

Duration: N/A, start: 1095.306211, bitrate: N/A
Program 4222

Metadata:

service_name : BBC ONE Wales
service_provider:

Stream #0:0[0x65]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv), 704x576 [SAR 16:11 DAR 16:9], max. 15000 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0:1[0x66](eng): Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 256 kb/s
Stream #0:2[0x6a](eng): Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels, s16p (visual impaired)
Stream #0:3[0x69](eng): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006)
Stream #0:4[0x98]: Data: bin_data ([6][0][0][0] / 0x0006)
Stream #0:5[0x96]: Unknown: none ([5][0][0][0] / 0x0005)
Stream #0:6[0x1c21]: Unknown: none ([11][0][0][0] / 0x000B)
Stream #0:7[0x1c33]: Unknown: none ([11][0][0][0] / 0x000B)
Stream #0:8[0x1c66]: Unknown: none ([5][0][0][0] / 0x0005)

[libx264 @ 0xc0a320] VBV maxrate unspecified, assuming CBR
[libx264 @ 0xc0a320] using SAR=1/1
[libx264 @ 0xc0a320] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 AVX2 LZCNT BMI2
[libx264 @ 0xc0a320] profile Constrained Baseline, level 3.0
[libx264 @ 0xc0a320] 264 - core 148 r2643 5c65704 - H.264/MPEG-4 AVC codec - Copyleft 2003-2015 - http://www.videolan.org/x264.html - options: cabac=0 ref=3 deblock=1:0:0 analyse=0x1:0x111 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=50 keyint_min=26 scenecut=0 intra_refresh=0 rc_lookahead=40 rc=cbr mbtree=1 bitrate=450 ratetol=1.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 vbv_maxrate=450 vbv_bufsize=450 nal_hrd=none filler=0 ip_ratio=1.40 aq=1:1.00
Output #0, flv, to 'rtmp://*.*.*.*:1936/tv':

Metadata:

encoder : Lavf56.40.101
Stream #0:0: Video: h264 (libx264) ([7][0][0][0] / 0x0007), yuv420p, 512x288 [SAR 1:1 DAR 16:9], q=-1--1, 450 kb/s, 25 fps, 1k tbn, 25 tbc
Metadata:

encoder : Lavc56.60.100 libx264

Stream #0:1(eng): Audio: aac ([10][0][0][0] / 0x000A), 48000 Hz, stereo, fltp, 64 kb/s
Metadata:

encoder : Lavc56.60.100 aac

Stream mapping:

Stream #0:0 -> #0:0 (mpeg2video (native) -> h264 (libx264))
Stream #0:1 -> #0:1 (mp2 (native) -> aac (native))

Press [q] to stop, ? for help
frame= 1 fps=0.0 q=0.0 size= 0kB time=00:00:00.19 bitrate= 16.8kbits/sframe= 13 fps= 13 q=0.0 size= 0kB time=00:00:00.55 bitrate= 5.8kbits/sframe= 26 fps= 17 q=0.0 size= 0kB time=00:00:01.15 bitrate= 2.8kbits/sframe= 39 fps= 19 q=0.0 size= 0kB time=00:00:01.62 bitrate= 2.0kbits/sframe= 51 fps= 20 q=23.0 size= 27kB time=00:00:02.11 bitrate= 104.0kbits/frame= 64 fps= 21 q=28.0 size= 54kB time=00:00:02.58 bitrate= 170.4kbits/frame= 76 fps= 22 q=28.0 size= 81kB time=00:00:03.30 bitrate= 201.5kbits/frame= 89 fps= 22 q=28.0 size= 113kB time=00:0[mpegts @ 0xbc26e0] PES packet size mismatchime=00:00:07.27 bitrate= 393.1kbits/s 26 bitrate= 305.5kbits/frame= 114 fps= 23 q=28.0 size= 185kB time=00:00:04.63 bitrate= 327.9kbits/s
[mpeg2video @ 0xc0d600] 00 motion_type at 41 7
[mpeg2video @ 0xc0d600] 00 motion_type at 0 28
[mpeg2video @ 0xc0d600] 00 motion_type at 0 27
[mpeg2video @ 0xc0d600] mb incr damaged
[mpeg2video @ 0xc0d600] 00 motion_type at 0 30
[mpeg2video @ 0xc0d600] 00 motion_type at 0 31
[mpeg2video @ 0xc0d600] 00 motion_type at 0 32
[mpeg2video @ 0xc0d600] 00 motion_type at 0 33
[mpeg2video @ 0xc0d600] slice mismatch
[mpeg2video @ 0xc0d600] 00 motion_type at 0 35
[mpeg2video @ 0xc0d600] Warning MVs not available
[mpeg2video @ 0xc0d600] concealing 1276 DC, 1276 AC, 1276 MV errors in B frame
[mp2 @ 0xc0daa0] Header missing
Error while decoding stream #0:1: Invalid data found when processing input
[mpegts @ 0xbc26e0] PES packet size mismatchime=00:00:14.01 bitrate= 351.0kbits/s
[mpeg2video @ 0xc0d600] ac-tex damaged at 23 28
[mpeg2video @ 0xc0d600] Warning MVs not available
[mpeg2video @ 0xc0d600] concealing 88 DC, 88 AC, 88 MV errors in P frame
[mp2 @ 0xc0daa0] Header missing
Error while decoding stream #0:1: Invalid data found when processing input
[mpeg2video @ 0xc0d600] ac-tex damaged at 5 34
[mpeg2video @ 0xc0d600] Warning MVs not available
[mpeg2video @ 0xc0d600] concealing 0 DC, 0 AC, 0 MV errors in B frame
[mpeg2video @ 0xc0d600] Warning MVs not available
[mpeg2video @ 0xc0d600] concealing 26 DC, 26 AC, 26 MV errors in P frame
[mpeg2video @ 0xc0d600] 00 motion_type at 37 2e=00:00:14.47 bitrate= 355.9kbits/s
[mpeg2video @ 0xc0d600] Warning MVs not available
[mpeg2video @ 0xc0d600] concealing 88 DC, 88 AC, 88 MV errors in P frame
[mpeg2video @ 0xc0d600] ac-tex damaged at 6 18
[mpeg2video @ 0xc0d600] Warning MVs not available
[mpeg2video @ 0xc0d600] concealing 88 DC, 88 AC, 88 MV errors in B frame
[mpegts @ 0xbc26e0] PES packet size mismatch
[mp2 @ 0xc0daa0] Header missing
Error while decoding stream #0:1: Invalid data found when processing input
[mpeg2video @ 0xc0d600] skipped MB in I frame at 4 10
[mpeg2video @ 0xc0d600] ac-tex damaged at 2 23

Then repeats all these warnings continuously.

Can watch the stream but it breaks up every few seconds and freezes etc with a distorted image.
Again, send the stream from the DVB source PC to the remote server and can watch it fine, it's only when encoding via 1gbps LAN. Both PCs have latest ffmpeg.

Version 0, edited 2 years ago by paule3d (next)

comment:3 Changed 2 years ago by cehoyos

Please test current FFmpeg git head and report back.

comment:4 Changed 2 years ago by paule3d

Thank you. This version works loads better in my case.

I removed -re as this was giving some "stream ends prematurely at" errors but now it seems stable.

Thank you very much!

comment:5 Changed 2 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Thank you for testing again!

Note: See TracTickets for help on using tickets.