Opened 3 years ago

Closed 3 years ago

#6060 closed defect (fixed)

Cannot compile with --disable-error-resilience

Reported by: ioeir2 Owned by:
Priority: normal Component: build system
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
Cannot compile (linking error) latest git-master version with --disable-error-resilience on Mac OS and Ubuntu x86_64.

How to reproduce:

./configure --disable-error-resilience
make -j8

Compilation error:

LD . ffprobe_g
LD . ffmpeg_g
LD . ffplay_g
LD . ffserver_g
Undefined symbols for architecture x86_64:
  "_ff_mpv_reallocate_putbitbuffer", referenced from:
Undefined symbols for architecture x86_64:
  "_ff_mpv_reallocate_putbitbuffer", referenced from:
Undefined symbols for architecture x86_64:
  "_ff_mpv_reallocate_putbitbuffer", referenced from:
Undefined symbols for architecture x86_64:
  "_ff_mpv_reallocate_putbitbuffer", referenced from:
      _ff_mjpeg_encode_stuffing in libavcodec.a(mjpegenc_common.o)
      _ff_mjpeg_encode_stuffing in libavcodec.a(mjpegenc_common.o)
      _ff_mjpeg_encode_stuffing in libavcodec.a(mjpegenc_common.o)
      _ff_mjpeg_encode_stuffing in libavcodec.a(mjpegenc_common.o)
ld: symbol(s) not found for architecture x86_64
ld: symbol(s) not found for architecture x86_64
ld: symbol(s) not found for architecture x86_64
ld: symbol(s) not found for architecture x86_64
clang: clangerror: : linker command failed with exit code 1 (use -v to see invocation)error: linker command failed with exit code 1 (use -v

clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [ffprobe_g] Error 1
make: *** Waiting for unfinished jobs....
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [ffserver_g] Error 1
make: *** [ffmpeg_g] Error 1
make: *** [ffplay_g] Error 1

Attachments (1)

log.txt (100.7 KB) - added by ioeir2 3 years ago.
Compilation log

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by ioeir2

Compilation log

comment:1 Changed 3 years ago by ioeir2

The following ffmpeg versions also cannot be compiled with --disable-error-resilience:
ffmpeg-3.2.2
ffmpeg-2.8.10
ffmpeg-2.6.9

comment:2 Changed 3 years ago by cehoyos

  • Keywords regression added
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Regression since 58f63670
Should be fixed in f3adb6f74b8c39c0da8d828c962e61cd2692fc4c, thank you for the report!

Note: See TracTickets for help on using tickets.